PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

1.4.2 Slow and buggy

  1. brent
    Member

    Just upgraded to 1.4.2 and am finding it to be extremely slow, sometimes unresponsive and hence buggy. Using the latest version of Firefox and finding it extremely difficult to even get a new form created. Many fields will simply not add to the form, but if they eventually do, I cannot edit all of them, for instance the email field. To give you a sense for how long some things are taking. I clicked to add an email field, and it took 20 seconds for the field to actually show up on my form.

    Posted 8 years ago on Monday September 20, 2010 | Permalink
  2. @brent There was nothing changed in 1.4.2 that would cause Gravity Forms to slowdown nor introduce bugs. The primary things changed in 1.4.2 were related to character encoding on export functionality for forms and entries and a minor CSS change.

    Nothing was changed with the form builder itself and we don't have any other reports of 1.4.2 introducing bugs or slowdowns.

    If you are having speed issues related to adding fields on your form then you are encountering server performance issues related to your web hosting.

    Posted 8 years ago on Monday September 20, 2010 | Permalink
  3. kojuka
    Member

    Its definitely slow for me too. not necessarily when displaying a form, but as soon as I activate gravity forms, my entire wordpress admin area slows to a crawl. Depending on the server it sometimes becomes unusable and I have to resort to less capable contact form plugins.

    Posted 8 years ago on Monday October 11, 2010 | Permalink
  4. @kojuka As I mentioned above, no changes were made in 1.4.2 that would introduce any kind of performance issue. This will be some sort of server configuration issue or possibly even a plugin conflict that is causing the slowdown.

    Posted 8 years ago on Monday October 11, 2010 | Permalink
  5. vixvii
    Member

    I have the same problem as brent. When adding fields I would click on a field and would have to wait 20+ seconds for it to display. Sometimes you would have to double click a field so that 2 fields appear 20 seconds later and delete the one.
    I haven't used any previous versions and I love gravity Forms. As a first impression I have to say that I got turned off by the speed. I really think it must be a plugin clash of some sort... brent, what plugins do you have activated at the moment? Maybe we can find something in common?

    Posted 8 years ago on Saturday January 15, 2011 | Permalink
  6. It could be a plugin clash, but it could also be a client side issue or server performance issue with the AJAX callbacks. Typically it is not that slow. The form builder is built entirely of Javascript utilizing AJAX. If you have a lot of fields on your form, this consists of a lot of client side Javascript so if your computer is slow or you are using a slow older browser... it can be slow. The form builder also uses AJAX, so if your web server is slow to respond to the AJAX requests, this can slow it down also.

    Posted 8 years ago on Saturday January 15, 2011 | Permalink
  7. vixvii
    Member

    This is definately a browser issue. I am running it on Firefox 3.6.9 and it is extremely slow. But on IE 9 Beta it works like it should. At least I know where to troubleshoot now :-)
    Thanks

    Posted 8 years ago on Monday January 17, 2011 | Permalink
  8. Hi,
    the site is running slow when the submit button is pressed of a specific form
    thanks

    Posted 6 years ago on Friday April 19, 2013 | Permalink