PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

A story about email notification not working.

  1. My business is a service business so receiving email leads is the same as a shopping cart for a product business.

    With that in mind I've been keen to move away from cformsII to something I thought would be a more robust way of handling leads. Gravity Forms have a good reputation so I forked out some money for a license.

    Here's the story, for what it's worth.

    1. Day 1. Install gravity forms on WP 2.9.2. No problem, everything works well. Easy to use, very pleased.
    2. Start to test email notifications from my contact me form. Received the email in the Entries folder but no email notification forwarded. Saw that I need to install a smtp plugin. No problem.
    3. Installed wp-email-smtp and confirmed settings for my Google Apps email. All good. Still no email notification.
    4. Checked gravity forms forums. Saw all the issues. Decided to sleep on it and reinstalled cformsII (which does work).
    5. Day 2. Sat down and wondered whether this was worth the effort, jeez it was only a form... but my leads came through it, so pressed on.
    Started trolling through the gravity forms folder:
    FAQ « Gravity
    FAQ « Gravity
    Administrator emails « Gravity Support Forums
    Email Notifications Not Being Dispatched « Gravity Support Forums
    Notifications HELP! « Gravity Support Forums
    No notification e-mails being sent « Gravity Support Forums
    Gravity Support Forums
    FAQ « Gravity
    Settings « Gravity
    Notifications « Gravity
    6. Figured that Gravity Forms was correct that is was an smtp issue and focused on the wp-mail-smtp plugin, in particular
    http://www.callum-macdonald.com/code/wp-mail-smtp/
    http://www.callum-macdonald.com/2008/12/12/wp-mail-smtp-v08/comment-page-2/#comment-35687
    Nice chap that Callum and good on him for offering a free plugin. But after a while I figured he was correct it was a server issue (php.ini). Next stop my web hosting company nexcess.net.
    7. I've had a very good experience with my nexcess reseller account so I thought I'd find the answer there. Not in the knowledge base.
    8. Really started to wonder if my contact form was that important... decided it was.
    9. Knowledge base said that if I wanted to change the php.ini I would have to contact them. Fair enough, it was smtp and with all those crackers out there...
    10. Contacted nexcess. They said "We don't offer open smtp access you need to authenticate in order to use our smtp server." And also suggested changing the port to 587.
    Still no luck.
    11. While they're checking authentication have more coffee and lunch.
    12. Numerous exchanges of emails.
    13. More coffee.
    14. Nexcess suggests I don't use smtp.gmail but their own server. Makes perfect sense. And works to my gmail address.
    The Solution in wp-mail-smtp:
    -mail.yourdomain.com
    -port: 25
    -use smtp authentication
    15. But not to my google apps gmail address. I was so close...

    The lesson for me - don't keep digging that hole.

    Lesson for Gravity Forms - my opinion is that this is an incomplete solution for the most important form of all - Contact Me form. A complete solution, like a shopping cart with paypal/google checkout/authorize.net etc, needs to integrate with the most common services. I think that gmail is a fairly common service ;) and my server runs on LAMP. A missing bit of information took 24 hours to track down, making this probably the most expensive plugin I've ever purchased - and I'm still goin'. Boy am I a sucker for punishment, thank god this isn't for a client.

    The guy from wp-mail-smtp is looking for someone to takeover support of his plugin, perhaps its time to do that or create a fork for your own plugin.

    Alternatively provide a much better knowledge base for the email notification part. Or a disclaimer that its not really a full solution for a contact form. I dunno but this just isn't the best experience from a fellow start-uper.

    Right time for more coffee.

    -Bruce

    Posted 10 years ago on Wednesday June 30, 2010 | Permalink
  2. Well, you've had a bit of a roll getting things set up it seems. I wish I could say I found the story entertaining. It sounds like in the end it all boils down to your host/mail server configuration. I don't see how based on that you can state that the plugin is by any means an "incomplete solution" for sending a contact form.. that's a bit of a stretch.

    For the vast majority of our users (in the thousands now) the built in WordPress mail functions work just fine. For the occasions when it doesn't, the SMTP plugin generally does the trick. We purposely chose not to add SMTP functionally because the majority of the time it's not needed and would just bloat the code.

    Even if we if we had built in SMTP support, there would still obviously be issues from time to time. We couldn't possibly account for the thousands of different server setups out there.

    I'm sorry that you've had a rough time getting going and as we move forward, we'll keep expanding our documentation and FAQ's to make that a better resource so hopefully it will help with any future issues you may have.

    That said, I still fail to see how the story ends with Gravity Forms at fault.

    Here's another related thread you might want to refer to as well.

    http://forum.gravityhelp.com/topic/are-there-any-debug-options-for-troubleshooting-mail-delivery#post-6815

    Posted 10 years ago on Wednesday June 30, 2010 | Permalink
  3. To finish off this post for the benefit of any sucker reading it ;)

    I did a filter in my gmail account to my business google apps account based off a unique subject from the contact form.

    That fixed it. Now if someone tries to contact me it goes to the right email address.

    Right time to move on.

    Posted 10 years ago on Wednesday June 30, 2010 | Permalink
  4. Glad you got it working. Thanks for the update. I'm sure somebody will find it helpful.

    Posted 10 years ago on Wednesday June 30, 2010 | Permalink

This topic has been resolved and has been closed to new replies.