PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Another api Mailchimp error

  1. leonardchiu

    With reference to this post:

    I have look through my entire plugin lists and could not find any other plugins that uses mailchimp therefore I am quite sure there isnt any conflicting plugins, however it is still not validating my API key.
    However to note, prior to purchasing GF, i used to embed code directly from Mailchimp to a HTML/PHP block. I'm not technically knowledgeable enough to know it that is conflicting. I have delete the block since but it is still not working.

    I guess contact Mailchimp will have the same result therefore I thought someone might be able to help me here. My main reason of getting GF was to link to Mailchimp..

    Any help here greatly appreciated!

    just realized that there was an update to mailchimp add-on 1.5 yesterday. Is it a problem with the new update?

    Posted 12 years ago on Wednesday June 29, 2011 | Permalink
  2. leonardchiu

    Another issue I find it strange is that the initial setup settings didn't ask for username & password? I read all your documentation on add-on Mailchimp & watch a video demo, all suggested username & pw. But instead it ask for API key which i created a new one for it and copy it direct from Mailchimp.

    Is there anything wrong with this?

    Posted 12 years ago on Wednesday June 29, 2011 | Permalink
  3. MailChimp has updated their API and they now use a different form of authentication based on the API key, and not username and password anymore. Our documentation is still reflecting the old authentication (something we need to update).
    I will be glad to take a closer look at your problem and try to figure if there is anything wrong on our side. Can you send me a WP admin login to Please include a link to this thread.

    Posted 12 years ago on Wednesday June 29, 2011 | Permalink
  4. leonardchiu

    Hi Guys!

    Sorted out the problem. Apparently it is my hosting that restrict outbound HTTP connections.
    Contacted them to whitelist the URL & IP address and it worked like a charm.

    For those might encounter this problem.
    Here's what i provide them (insert which server your account is from. e.g. "us2")
    or these ip address

    Thanks Alex for your help

    Posted 12 years ago on Friday July 1, 2011 | Permalink

This topic has been resolved and has been closed to new replies.