PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Approval of Submissions Before Being Published?

  1. John
    Member

    I was searching through the existing threads to see if others have made this inquiry. This is closest: http://www.gravityhelp.com/forums/topic/upload-approval, but it doesn't quite solve what I am looking for.

    Gravity Forms is setup on my Wordpress site so that registered users (who have the "Contributor" role) can fill out the form to post content on the site. After they fill out the form, the fields that they entered and the photos that they uploaded will essentially appear on the frontend of the site as a a typical blog post — title, post meta, content, photos, and tags. Basically, these are "guest blog posts." However, instead of these "guest blog posts" being written in the WP dashboard, these contributors are filling out a Gravity Forms form.

    My inquiry is — is there a way for these "guest blog posts" submitted by contributors to require moderation from an admin before being published live on my Wordpress site? Currently, when a contributor completes the form and submits the content, it becomes published immediately. However, from my understanding of WordPress roles, contributor posts must always require admin approval (source: http://codex.wordpress.org/Roles_and_Capabilities) before being published. How come in my case, it is not behaving as such? Is Gravity Forms possibly overriding a WP function?

    Posted 7 years ago on Thursday August 2, 2012 | Permalink
  2. John, the post title and post body fields allow you to set status to Draft: Screenshot Do you have your settings on one of those fields to do otherwise?

    Posted 7 years ago on Thursday August 2, 2012 | Permalink
  3. John
    Member

    Wow, thank you very much, Rob! I must have overlooked that setting completely. I just changed it now and tested it, and it works exactly how I want. Really appreciate your help!

    Posted 7 years ago on Thursday August 2, 2012 | Permalink

This topic has been resolved and has been closed to new replies.