PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Authorize.net add-on (beta): "There was an error processing your credit card."

  1. Authosize.net Plugins keeps telling an error.

    There was an error processing your credit card. Please verify the information and try again.

    We have setup it with test account. The card used was given by the authorize.net sandbox.

    How can we passed this error, because of this we cannot test the registration.

    Posted 6 years ago on Wednesday February 8, 2012 | Permalink
  2. Hi Elevated Atheletics,

    Try using the below information:

    Test Credit Cards (to be used when filling out the form)
    American Express: 370000000000002
    Discover: 6011000000000012
    Visa: 4012888818888
    JCB: 3088000000000017

    Security Code: (to be used when filling out the form)
    900 (for success)

    Let me know if you are still getting an error.

    Posted 6 years ago on Monday February 13, 2012 | Permalink
  3. UPDATE: It's because I wasn't defining a "country." It's working now.

    I'm getting the same thing...

    https://www.rankpop.com/new-account/

    My account is in "real" mode currently

    I've tried 5 different cards.

    There are no transactions showing up in authorize.net (declined or otherwise)

    Must I supply a country in the address field?

    Posted 6 years ago on Wednesday February 22, 2012 | Permalink
  4. Im having the same issue, however I'm in production mode. Everything is filled out and once i click submit i get the error.

    Posted 6 years ago on Thursday February 23, 2012 | Permalink
  5. I love this plugin and have been waiting for it for months... years really.

    Anyways, I have recently run into some issues when processing a credit card. The customer got the warning "There was an error processing your credit card. Please verify the information and try again."

    He tried again and again, and each time He did Authorize.net took his payment - but the website said there was an error. Thankfully I had the authorize.net account transactions set to be held for review. I voided all transactions but one, but the question remains - how could this happen?

    This is the first time processing on this site, lapelpindesign.com but the same form was imported from my other site pinsfast.com . I noticed one key difference and made a change - the address was set to international, but hid the country field. I changed it and processed one of my own cards as a test. I still got the decline error and the transaction was processed. I tried a different card and there was no error - that card was also processed. I am quite confused.

    Seems like if a credit card is declined by the form, it should not be accepted by authorize.net. This could lead to big problems if not fixed.

    Any help would be appreciated!

    Posted 6 years ago on Monday April 2, 2012 | Permalink
  6. Update on the last problem:

    I have found the problem and made changes in our form to correct it. The form was asking for "address", but it did not specify that it needed a billing address. When the customer entered his shipping address into that area it gave him an error. The form now asks specifically for the billing address and shipping adress. This will eliminate future problems.

    I simply ask for the billing address, making sure it is US not international fields. Then I place a checkbox below asking "is your shipping address different than your billing address?" - then if the checkbox is clicked, a conditional logic brings the shipping address fields up.

    Both address fields are required, but if the checkbox is not clicked, the empty shipping fields do not create an error because the condition for them was not met. I am very happy!

    Posted 6 years ago on Tuesday April 3, 2012 | Permalink
  7. I keep getting the same error, and when viewing the source I see this:

    Error: 87

    Any ideas what that error would be?

    Posted 6 years ago on Tuesday July 10, 2012 | Permalink
  8. Looks like this is the reason for error code: 87 - https://support.authorize.net/authkb/index?page=content&id=A597&actp=LIST

    Posted 6 years ago on Tuesday July 10, 2012 | Permalink

This topic has been resolved and has been closed to new replies.