PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Aweber authorizaion code not working

  1. hi,
    my aweber authorization code is not working. i filled in my aweber login data.
    any idea what i am doing wrong?
    thank you
    barbara

    Posted 6 years ago on Monday July 16, 2012 | Permalink
  2. David Peralty
    Administrator

    Can you give us more information. What versions of Gravity Forms and WordPress are you using? Where are you getting your AWeber authorization code? What error are you getting?

    Posted 6 years ago on Monday July 16, 2012 | Permalink
  3. i have just bought gravity forms, so it is 1.6.4.5.4, Aweber add-on 1.3, Wordpress is 3.3
    i want to use the aweber plugin, therefore i have to go to settings->aweber:
    Click here to retrieve your Authorization code.
    and there i have to fill in my login data from aweber, which i do - then copy the received api into your field and there stays a red sign which says at mouseover:
    "invalid API Credentials. Please try another" Also when i press "save settings"
    The login data works to login at aweber.
    best,
    barbara

    Posted 6 years ago on Friday July 20, 2012 | Permalink
  4. Have you tried typing the API key in rather than copying and pasting? Sometimes extra characters tag along and foul things up.

    Posted 6 years ago on Friday July 20, 2012 | Permalink
  5. I'm having the same problem.

    Posted 6 years ago on Friday July 20, 2012 | Permalink
  6. no, nothing, i've been taking care of this. i've tried typing myself - nothing.

    i also created a new aweber account - nothing

    this is really getting a problem, my client who is needing this, is getting impatient

    thank you

    Posted 6 years ago on Saturday July 21, 2012 | Permalink
  7. up-gyf, can you update this site to the latest WordPress?

    Posted 6 years ago on Saturday July 21, 2012 | Permalink
  8. done. no change.

    i also tried deactivating contact form 7 - which we use until gravity forms works the way it should

    this is really getting a problem here, because credit cards have already been charged and nothing works.

    any more ideas? thank you very much

    barbara

    Posted 6 years ago on Monday July 23, 2012 | Permalink
  9. up-gyf, can you post a screenshot of the error you are receiving? I can't find that exact error language anywhere in the AWeber docs. Their API documentation is here.

    https://labs.aweber.com/docs/troubleshooting

    I was able to authorize and get an API key and paste it in to the Gravity Forms settings page and it worked fine.

    Sounds like there is something conflicting on the server causing this problem for you, as the functionality of the plugin works.

    Posted 6 years ago on Tuesday July 24, 2012 | Permalink
  10. andy, same for you. Please post the exact error response you are receiving. Thank you.

    Posted 6 years ago on Tuesday July 24, 2012 | Permalink
  11. I am having the same problem
    I am using Wordpress 3.4.1, Gravity Forms 1.6.7, Aweber addon 1.3
    I have tried multiple times to load the authorization code give bt pressing the click here etc and it just wont accept it
    Mouseover the reddot gives "Invalid API Credentials. Please Try another"

    The site is on http://www.bodywisefoodsmart.com hosted with Blue Host. It worked great on my test server on Hostgator

    Posted 6 years ago on Thursday September 6, 2012 | Permalink
  12. ..ok, client couldn't wait for this to be solved, so I have recreated the form in HTML. I am really diappointed that this failed - I have been a huge fan of Gravity forms and persuaded a client who gives me lots of repeat work to use this on her sites... and now it has failed, and she wants all Gravity forms replaced across all her sites.
    Has anyone else had problems with Blue Host and Aweber Addon?

    Posted 6 years ago on Thursday September 6, 2012 | Permalink