PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

"Broken" Forms & Credit Card Processing

  1. I am using Gravity Forms 1.6.12 running on WordPress 3.4.2. Also using the Authorize.net add-on 1.3 to tie into my clients credit card processing company.

    My client is a transportation/shipping company. Pricing for their client varies by regions of the nation so I have several dozens forms. The orders are either scheduled by my direct client or by the store manager (they deliver for national chain) in a password protected area.

    These forms have been set-up for months and months. We've processed hundreds of them for hundreds of thousands of dollars without ever a single issue (my client LOVES your product BTW -- as do I -- you make me look smarter than I am).

    Problem/Issue

    With that background I almost don't know where to start. Basically the forms are starting to "fail" in a cascading manner. First it was the email notifications, which I posted about here.

    With all the forms I have we need the EXACT same customer information, so at the start I created one form, then duplicated it for the other stores with the only edits being the store #, address, and shipping charges. Again they've worked without a glitch for almost a year.

    Now some work, some don't.

    By not work I mean some won't process a credit card, even though we know it is valid. You enter the info, lets you go to the other screen to click a box agreeing to the Disclaimer, but when you submit it pops you back with the red field around the credit card information.

    Others will process the order, but it never gets to Authorize.net.

    In other instances a form will work a number of times, and then just stop working.

    We are also always updating the forms. Testing different pricing is the main thing. I've tried to backtrack and see if one edit here or there "broke" the form, but alas I can't figure it out.

    Finally I realize this is like an impossible Help Ticket to address, but alas it is why I need help cause I can't figure it out for the life of me.

    Here is one of the forms that I have made public so folks can look at it. I am so desperate I'd even give you my WP log-in info if somebody from Gravity Forms want to email me.

    Update: I should note the above form in fact was working this morning. It is the EXACT same as the forms that are not working.

    Tommy

    Posted 6 years ago on Monday March 4, 2013 | Permalink
  2. By not work I mean some won't process a credit card, even though we know it is valid. You enter the info, lets you go to the other screen to click a box agreeing to the Disclaimer, but when you submit it pops you back with the red field around the credit card information.

    When this happens, view the source of the page and look for that error message. Next to it, you will find a comment with an error code in it (eg: <!-- Error: 99999 -->). That error code will help yo troubleshoot the cause of the problem. You can look up the error codes here: http://www.authorize.net/support/merchant/Transaction_Response/Response_Reason_Codes_and_Response_Reason_Text.htm

    Additionally, I can send you a logging add-on which may help you troubleshoot this in more details. Send and email to chris@rocketgenius.com and I will email it to you.

    Finally, because you are a developer license holder, you can always use our priority support form http://www.gravityhelp.com/priority-support/ . If you do, please include a link to this topic.

    Posted 6 years ago on Monday March 4, 2013 | Permalink