PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

BuddyPress 1.5 Activation Workaround

  1. I set up a custom Registration form using Gravity Forms.

    The WP user was created, and the BP user meta was populated perfectly.

    An email was sent out to the user as expected, but the email only contained Username, Password, and a link back to wp-login. There was no link to, or mention of a BuddyPress activation key in the email.

    Logging the user on worked just fine, and it seems that the user has the correct role, and has the correct access on the site.

    I assume that the BuddyPress activation process was bypassed by using Gravity Forms?

    I would prefer to have activation as an extra measure to prevent bogus registration.

    I know that the User Registration add-on doesn't currently support the BP activation (but it is hopefully on the list to add in a future GF release).

    What I am hoping is that someone could help me with a temporary workaround until the User Registration add-on is updated to include BP activation?

    BuddyPress 1.5 is getting a LOT of attention since it has addressed many past issues, and it will be heavily used in the future. Having this work with GF is the right move.

    Thanks!

    Posted 10 years ago on Thursday September 15, 2011 | Permalink
  2. The User Registration Add-On uses the WordPress user creation function and not any BuddyPress specific functionality. What we can do is look into how BuddyPress handles this and then either add an option or automatically use the BuddyPress process if BuddyPress is activated. I'm not 100% sure of a work around but I can have our developer that works on this Add-On take a look.

    Posted 10 years ago on Thursday September 15, 2011 | Permalink
  3. Hi Carl,

    I would greatly appreciate it if your developer could look at a work around until the User Registration Add On is updated for BuddyPress functionality.

    I hate to ask (know you are busy on 1.6 roll out), but do you think the developer could look at this relatively soon? I have a need for it .... yesterday lol :)

    Anything you can do will be greatly appreciated.

    Posted 10 years ago on Thursday September 15, 2011 | Permalink
  4. sboisvert@bryxal.ca
    Member

    +1

    Posted 10 years ago on Thursday September 15, 2011 | Permalink
  5. Hi Carl,

    Any possibility of a temporary workaround until the User Registration add-on is updated?

    BP 1.5 is RC1 now, with no changes expected, and release to public should be this week. It would be awesome if you could help on this.
    Thank you.

    Posted 10 years ago on Tuesday September 20, 2011 | Permalink
  6. Hi WebEndev,

    I will take a look a look at this today/tomorrow and get back with you. :)

    Posted 10 years ago on Tuesday September 20, 2011 | Permalink
  7. Hi WebEndev,

    We took a look and unfortunately this isn't something that we'll be able to resolve immediately. The way the user is currently created in the add-on is not compatible with how BP and WPMS handle the activation link. We're definitely planning on adding this functionality as soon as we can.

    In the meantime, I'll see if I can't work you up a work around solution over the weekend. :)

    Posted 10 years ago on Wednesday September 21, 2011 | Permalink
  8. HI David,

    MAN the work around would be a life saver... :)
    I'm glad I elevated this though so the add-on can be enhanced to add the functionality.

    Appreciate it much sir!

    Posted 10 years ago on Thursday September 22, 2011 | Permalink
  9. Hi David,

    We are building a membership based site (with Buddypress), and hope to release the site in the next few days.

    When we installed and implemented the User Registration Add-on we didn't realise that would mean sacrificing the email activation.

    This functionality is very important to us and we would love to hear some good news regarding this topic.

    Thanks, Alex.
    Business Advisor Network.

    Posted 10 years ago on Friday September 23, 2011 | Permalink
  10. Hi David,

    Did you find a workaround to this?

    Thanks very much for your help!

    Posted 10 years ago on Tuesday September 27, 2011 | Permalink
  11. Hi David,
    We are about to launch our site need to figure out a work around soon. Can you give us all a time frame that there might be a solution to this? Like, workaround in X days and update in Y days that includes a permanent solution. This is very important for us to go live.
    Peter
    Director
    Business Advisor Network

    Posted 10 years ago on Tuesday September 27, 2011 | Permalink
  12. Hi Guys,

    Apologies for the delayed update. After digging even deeper into this functionality it looks like there is no such thing as a simple work around for this. If the workaround was simple and supportable, I'd be more than happy to whip this up in my free time; however, the User Registration Add-on integrates with many other add-ons and WordPress features that require more careful consideration when altering code.

    Again, we are planning on supporting this functionality moving forward. We do not have a time frame for when this functionality will be added to the User Registration Add-on. I will be sure to update this thread when we do.

    Posted 10 years ago on Wednesday September 28, 2011 | Permalink
  13. Hi David,

    Thanks for looking into it for us. I will be waiting and hoping that your time frame for updating the User Registration Add-on is soon.... :)

    Thanks again for your help in this.

    Posted 10 years ago on Wednesday September 28, 2011 | Permalink

This topic has been resolved and has been closed to new replies.