PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Does the MailChimp Addon 1.0 work with Gravity Forms 1.4.5

  1. WHIMPEYD
    Member

    I've purchased a copy of Gravity Forms for a website I'm building & the Mail Chimp addon plugin isn't working. http://www.caraskarma.org/fanclub & soon to be .com (I use .org to test 1st)

    When I uploaded the Mail Chimp Addon 1.0 & activated it, it gives me this message when I try to add a new feed: "Could not load MailChimp contact lists.
    Error: Invalid Mailchimp API Key: ea260518a2cef8b6f5a66d217a77020f-us2 . You are accessing the wrong datacenter - your client library may not properly support our datacenter mapping scheme. " This doesn't occur on my other website http://www.chickfriendly.net/talk-to-us . (That site is running Gravity Forms 1.3.12)

    Even though I've validated the Mail Chimp account through the plugin's settings page, this message appears. Is this a version conflict? I can't update the Mail Chimp plugin because Gravity Forms doesn't recognize the registration of my Form. The message below the plugin reads: "Register your copy of Gravity Forms to receive access to automatic upgrades and support. Need a license key? Purchase one now."

    Posted 9 years ago on Wednesday December 29, 2010 | Permalink
  2. You are trying to use an old version of the MailChimp Add-On. 1.0 is old, the current version is v1.3.1 and it's available to Developer License holders on the Add-Ons page.

    I don't see a Developer License registered to your email address, it appears you own a Single Site License unless you used a different PayPal email address to purchase the Developer License.

    Posted 9 years ago on Wednesday December 29, 2010 | Permalink
  3. Mary Hutson
    Member

    Hi,

    I'm having MailChimp API key problems. Here's the error message:

    MailChimp Feed
    MailChimp list (?) Could not load MailChimp contact lists.
    Error: Invalid Mailchimp API Key: 962378b135ebaa12737fe47e16c018e9-us2

    I copied the API key directly from MailChimp, so I don't think that's the problem.
    My form page lives here: http://hutsonresourcegroup.com/register-for-the-values-at-risk-conference-call/

    Posted 9 years ago on Wednesday January 12, 2011 | Permalink
  4. This may be a silly question, but have you created lists in MailChimp already? Your API key is validating, however MailChimp is saying no lists exist for that API key.

    Posted 9 years ago on Thursday January 13, 2011 | Permalink
  5. Mary Hutson
    Member

    Yes, I have a list. I've sent out mailings to it; everything within MailChimp is working as expected, but I can't get my Gravity form to dump into it.

    When I first added the API key, after installing the MailChimp addon, the API key was successfully accepted, so I thought the two programs were "talking" to one another okay....

    Posted 9 years ago on Thursday January 13, 2011 | Permalink
  6. It appears to be an issue with the MailChimp API itself.

    Please send us a WordPress Admin login for the site having the issue AND your MailChimp login so that we may investigate and debug. You can send this to us via our Contact Us form.

    Posted 9 years ago on Thursday January 13, 2011 | Permalink