PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Error on line 14 on Create Form

  1. unodewaal
    Member

    I seem to be getting this error:
    Notice: Undefined index: operation in /xxxxxxx/mktv.tpyo.net/wp-content/plugins/gravityforms/form_detail.php on line 14

    The line on that file is: if($_POST["operation"] == "delete"){

    The URL I am accessing this from is the New Form screen:
    http://mktv.tpyo.net/wp-admin/admin.php?page=gf_new_form

    any ideas?
    I've just bought the theme and activated it, so I've never had this installed before. I am running Wordpress 3.0 with a Network install (Multisite)

    (Sorry I added this to the wrong category by mistake!)

    Posted 10 years ago on Tuesday November 16, 2010 | Permalink
  2. Hard to tell from just that information as nobody else is reporting this issue. If you can send us a WordPress Admin Login via our Contact Us form and reference this forum post we can take a look and see what is going on.

    Posted 10 years ago on Tuesday November 16, 2010 | Permalink
  3. Shines
    Member

    Carl,

    Did you ever get this resolved? I'm getting the same error on our install (which is not a network install).

    Thanks,
    Sarah

    Posted 10 years ago on Monday December 20, 2010 | Permalink
  4. @Shines it was a bad install. The user had to completely uninstall Gravity Forms using the uninstall option on the Settings page (Forms > Settings) and then re-download the files and re-FTP them to his site and then activate.

    Posted 10 years ago on Monday December 20, 2010 | Permalink
  5. Shines
    Member

    Thanks Carl,

    I've uninstalled, and reinstalled using the official method.

    Now I'm now getting the same error on line 14, plus a new error (around gform_tooltip, which means the plugin dies before being able to do very much or be able to be registered).

    Are there other methods of double-checking it's completely uninstalled and cleared out before attempting to reinstall?

    I've also tried switching themes, and turning off all plugins except Gravity Forms to confirm it's unique to GForms rather than plugin interaction errors.

    Thanks,
    Sarah

    Posted 10 years ago on Wednesday December 22, 2010 | Permalink
  6. In order to debug this, it's an issue specific to your site, we would need access to your site to determine the issue. Ideally this would be a WordPress admin login and FTP login. You can send this information to us via our Contact Us form and reference this forum post and we can work with you to determine what is going on and get it resolved so you can get up and running as expected.

    Posted 10 years ago on Wednesday December 22, 2010 | Permalink
  7. Aaron Forgue
    Member

    Just FYI, getting similar errors upon activation of the plugin...

    I get this on multiple pages in the admin:
    Notice: Undefined index: page in /websites/stage.payperclickuniverse.com/public_html/wp-content/plugins/gravityforms/gravityforms.php on line 364

    And this on the New Form page:
    Notice: Undefined index: operation in /websites/stage.payperclickuniverse.com/public_html/wp-content/plugins/gravityforms/form_detail.php on line 14

    Fresh install of Wordpress 3.1, GF 1.4.5

    Posted 10 years ago on Wednesday March 9, 2011 | Permalink
  8. Aaron Forgue
    Member

    Ok, figured out what our problem was: we had WP_DEBUG enabled.

    Why was this a problem? Well, with WP_DEBUG enabled, PHP notices were being output. These outputs screwed up some of the GF JavaScript.

    So for example:
    This line in gravityforms/JS.php:

    field.inputs = [new Input(field.id + 0.2, '<?php echo apply_filters("gform_name_prefix_{$_GET["id"]}", apply_filters("gform_name_prefix", __("Prefix", "gravityforms"))); ?>'), new Input(field.id + 0.3, '<?php echo apply_filters("gform_name_first_{$_GET["id"]}",apply_filters("gform_name_first",__("First", "gravityforms"))); ?>'), new Input(field.id + 0.6, '<?php echo apply_filters("gform_name_last_{$_GET["id"]}", apply_filters("gform_name_last",__("Last", "gravityforms"))); ?>'), new Input(field.id + 0.8, '<?php echo apply_filters("gform_name_suffix_{$_GET["id"]}", apply_filters("gform_name_suffix",__("Suffix", "gravityforms"))); ?>')];

    Became this, since a notice was thrown:

    field.inputs = [new Input(field.id + 0.2, '
    <b>Notice</b>:  Undefined index: id in <b>/websites/stage.payperclickuniverse.com/public_html/wp-content/plugins/gravityforms/js.php</b> on line <b>699</b>
    Prefix'), new Input(field.id + 0.3, '
    <b>Notice</b>:  Undefined index: id in <b>/websites/stage.payperclickuniverse.com/public_html/wp-content/plugins/gravityforms/js.php</b> on line <b>699</b>
    First'), new Input(field.id + 0.6, '
    <b>Notice</b>:  Undefined index: id in <b>/websites/stage.payperclickuniverse.com/public_html/wp-content/plugins/gravityforms/js.php</b> on line <b>699</b>
    Last'), new Input(field.id + 0.8, '
    <b>Notice</b>:  Undefined index: id in <b>/websites/stage.payperclickuniverse.com/public_html/wp-content/plugins/gravityforms/js.php</b> on line <b>699</b>
    Suffix')];

    Moral of the story? Turn off WP_DEBUG or convince the GF devs to do a little more checking/validation of data returned by apply_filters.

    Hope this helps!

    Posted 10 years ago on Wednesday March 9, 2011 | Permalink
  9. @Aaron Forgue You have WP DEBUG mode turned on. These are debug notices, not error messages. They are notices. We clean up DEBUG related notices with each new release. If you don't want to see them, turn off DEBUG mode.

    Posted 10 years ago on Wednesday March 9, 2011 | Permalink
  10. Aaron Forgue
    Member

    @Carl, yup, that's what I said: Our problem was that we had WP_DEBUG on, which threw Notices and messed up some of the GF JS. Turning off WP_DEBUG fixed the problem.

    Posted 10 years ago on Wednesday March 9, 2011 | Permalink
  11. @Aaron Yep, didn't see your follow up reply until after I had responded so I had not seen that it was WP_DEBUG. We do clean up notices as we go along so these should be resolved in 1.5.

    Posted 10 years ago on Wednesday March 9, 2011 | Permalink
  12. Aaron Forgue
    Member

    @Carl, yeah after I made my post I realized that we crossed streams. Didn't mean to come across as snarky or rude.

    Thanks for the quick response and great plugin!

    Posted 10 years ago on Thursday March 10, 2011 | Permalink
  13. @Aaron Not at all Aaron, thanks!

    Posted 10 years ago on Thursday March 10, 2011 | Permalink