PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Error Processing Card on products/services only

  1. I have a form that uses the product options field to select Lump Sum, 6 Payments, or 12 Payments. The 6 and 12 payments work as expected; however, the Lump Sum does returns "There was an error processing your credit card." If I change the settings from Product or Service to Subscription it works. What am I doing wrong on the single product auth.net settings? It's really straight forward.

    I am using a billing address, send auth.net receipt, and auth.net condition.

    The form is located here: https://restlesslegtreatment.ca/checkoutclick/

    Thanks!

    Posted 7 years ago on Monday July 30, 2012 | Permalink
  2. David Peralty
    Administrator

    Which version of WordPress and Gravity Forms are you using? Is your product value currently $0? Looking forward to helping you solve this.

    Posted 7 years ago on Monday July 30, 2012 | Permalink
  3. WordPress 3.4.1
    Gravity Forms 1.6.5.1

    The product is user entry.

    Posted 7 years ago on Tuesday July 31, 2012 | Permalink
  4. Any ideas? I find it odd that the subscriptions work, but the single product doesn't. Is this a problem with the settings on Authorize.net Add-on or Gravity Forms?

    Posted 7 years ago on Tuesday August 7, 2012 | Permalink
  5. I went into the Auth.net setting in Gravity Forms and turned on logging.

    I get error 270

    Line Item 2 is invalid.

    Any ideas? I can't figure out what line item 2 is. On the log it's a 3.

    Posted 7 years ago on Thursday August 23, 2012 | Permalink
  6. Can you send me a WP admin login to rob@rocketgenius.com and reference this post in your email so I can take a look?

    Posted 7 years ago on Thursday August 23, 2012 | Permalink
  7. Resolved via email.

    Posted 7 years ago on Friday August 31, 2012 | Permalink

This topic has been resolved and has been closed to new replies.