PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Form submissions not being added to MailChimp list

  1. I'm running GF 1.5.rc2.1 and MailChimp add-on ver 1.3.1 on my site, http://www.johnmurray-realtor.com.

    I set-up the MailChimp add-on and added my API key, which was recognized. I think the API is working because when I configure the MC feed, it recognizes my list name. I have tried all settings for the Opt-in configuration, especially the simplest case, where it is disabled.

    However, after configuring the feed and making a form submission using a very simple form, no contacts appear on my MC list. I tried creating a 2nd MC list and configuring a feed to that list, and still nothing. I waited overnight, in case there was a problem with MC.

    Is this an issue with the 1.5 RC or is it something I might be doing wrong?

    Posted 9 years ago on Sunday December 19, 2010 | Permalink
  2. There are no known issues with the MailChimp Add-On with Gravity Forms v1.5. This is going to be some sort of configuration issue. If you send us a WordPress Admin login for your site via our Contact Us form we can take a look and do some testing with our own MailChimp account.

    Posted 9 years ago on Monday December 20, 2010 | Permalink
  3. Login info sent.

    Posted 9 years ago on Monday December 20, 2010 | Permalink
  4. I did some more testing on another domain on the same hosting account. After doing 5 form submissions, 2 of the 5 made their way to MailChimp after about 15 minutes. So far, the other 3 haven't shown up, more than 30 minutes later.

    I set this 2nd domain up the same way I did the first.

    Any thoughts? I'd like to get this working, since it was a big reason in purchasing.

    Posted 9 years ago on Tuesday December 21, 2010 | Permalink
  5. The first issue I see is you have 2 MailChimp feeds setup for 1 form.

    The MailChimp Add-On only supports 1 MailChimp feed per form. So this is most likely causing the issue.

    I did some tests on your site with my own MailChimp API Key and a Test Form I setup and I had no problems with the integration, it worked every time I submitted the form.

    The issue you are running into is due to having 2 integrations setup for 1 form, which isn't supported.

    You can only have 1 MailChimp integration feed setup per form currently. We can look into how to support multiple integrations per form, but for now it only supports 1 per form so you will have to remove one of them.

    Using multiple lists in MailChimp shouldn't really be necessary because you could use list segmentation to only send campaigns to a group within the list.

    Posted 9 years ago on Tuesday December 21, 2010 | Permalink