PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

https page unsecure

  1. chm_christine
    Member

    hi, we just setup the authorize.net plugin... we DO HAVE A SSL - however we are getting the "red box warning" on our form at:

    http://www.imilive.org/imi-correspondance-sign-up

    i'm not an expert at SSL by anymeans... my question is, since we DO have an ssl... will that plugin fix this problem??? WordPress HTTPS (SSL) Plugin ??? please advise...thanks

    Posted 7 years ago on Saturday February 18, 2012 | Permalink
  2. thegmann
    Member

    Hey I'm just a beta user but yes install the wordpress HTTPS plugin and check the checkbox for Force SSL Exclusively on the settings page. Go to the page your form is displayed on and check the "Force SSL" box above your Update button, then hit update, that should make it so your form page displays using SSL exclusively and should fix the form problem.

    Posted 7 years ago on Saturday February 18, 2012 | Permalink
  3. thegmann
    Member

    Also, your page appears to be infinitely refreshing in my browser. I had a similar problem and the problem was that my shopping cart system was trying to force the page to be insecure since it was not a shopping cart page, while my form page was set to be secure, so the plugins were fighting over it. Make sure you don't have any conflicting plugin settings.

    Posted 7 years ago on Saturday February 18, 2012 | Permalink
  4. chm_christine
    Member

    hi...

    well, i did install the https SSL plugin... and i am still getting the "red warning" box... is it possible our SSL is installed incorrectly?

    as for the contant refreshing of the page... at:
    http://www.imilive.org/imi-correspondance-sign-up

    i am still working to see what plugin might be causing this...

    Posted 7 years ago on Tuesday February 21, 2012 | Permalink
  5. @thegmann Thanks for the tips. This helped resolve some of the SSL/https issues we were trying to overcome.

    Posted 7 years ago on Tuesday February 21, 2012 | Permalink
  6. chm_christine
    Member

    here is what fixed it for us...in case someone else needs this... but in your .htaccess file:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

    Posted 7 years ago on Friday March 2, 2012 | Permalink