PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Invalid API Credentials. Please try another.

  1. Hi,

    I am using 'Gravity forms AWeber Add-on" and tried to add API credentials generated from https://auth.aweber.com/1.0/oauth/authorize_app/2ad0d7d5 number of times, but no luck so far. It always shows red-symbol (Invalid API Credentials. Please try another.) under AWeber settings.
    ===
    WordPress version: 3.5.1
    Gravity Forms version: 1.6.12
    Gravity Forms AWeber Add-on version: 1.3
    ===

    Any quickest help would be highly appreciated.

    Thanks,
    Dipak G.

    Posted 5 years ago on Friday March 1, 2013 | Permalink
  2. Please begin by checking for plugin and theme conflicts using these instructions http://rkt.gs/testing

    Are you successfully logging into your AWeber account?

    Posted 5 years ago on Saturday March 2, 2013 | Permalink
  3. Hi Chris,

    I already gone through theme/plugin conflict test but no luck. I tried by changing theme to 'twenty twelve / twenty eleven' and also deactivated all the plugins and then only activated GF and GF-AWeber Add on. I am currently using 'OptimizePress' theme for WP and Amzon EC2 - CentOS server.

    Yes, I am able to login into AWeber successfully and can generate authorization code without any issues, but when I add it into settings, it never works and shows red icon at the end of key-input box (Invalid API Credentials. Please try another.).

    Do I need to set-up anything special under server? I don't think so.

    Thanks for your cooperation,

    Dipak G.

    Posted 5 years ago on Saturday March 2, 2013 | Permalink
  4. Hi Chris,

    Finally I have managed to fix this issue at my own. Actually in Server, Curl was disabled which I have enabled (I have found in AWeber API Documentation that Curl should be enabled for authorization) and it worked :)

    *You can add this in 'Plugin Requirements' if you want.

    I hope this may help someone having the same issue.

    Many thanks,

    Dipak Gajjar

    Posted 5 years ago on Saturday March 2, 2013 | Permalink
  5. Thank you for posting that discovery.

    Posted 5 years ago on Saturday March 2, 2013 | Permalink

This topic has been resolved and has been closed to new replies.