PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

LInk to register is failing due to too many redirects

  1. I've just updated to WP 3.5, and updated all plugins and the theme I'm using Classipress.
    For registration I’m using Gravity Forms registration.
    I'd tried the updates out in a test environment, which is pretty much identical to the live. Everything worked fine in the test environment. However in the live environment, when I try to register in Firefox, IE and Chrome, they are all hanging or telling me there are too many redirects.
    The links to the registration page are to http://www.yours2share.com/register/ but the Gravity Form code is in a page http://www.yours2share.com/dashboard/register/ as required by Classipress. If I go direct to http://www.yours2share.com/dashboard/register/ the registration form appears and works perfectly.
    Somewhere there must be a setting to redirect the default sign-up to http://www.yours2share.com/register/ and then a further setting to redirect this to http://www.yours2share.com/dashboard/register/ but I can't work out or remember where. I’ve been through all the Classipress and Gravity Forms settings. If someone can tell me I’d be very grateful. It seems to me that I need to tell something to go direct to http://www.yours2share.com/dashboard/register/
    I’m looking for admin settings because I've changed very little code, and I don't think I've altered anything that. The only things I’ve altered are in a Classipress child theme, but the changes are generally only style or things that are very specific to my site and registration isn't something I would consider to be specific to my site, so I'd do everything to avoid fiddling with it.
    However if someone can tell me the Gravity Forms or Classipress files that control this, I will check that I haven’t amended something. It would help if I knew where the files that control the Register option in the top bar and the Register link beneath the Classipress welcome box that appears on the home page. If necessary I’ll hard code these to the link that I know works as a temporary fix.
    Any help would be very gratefully received.

    Posted 7 years ago on Thursday January 17, 2013 | Permalink
  2. I've worked out what was doing the redirecting: a plugin called Registration Redirect, unsurprisingly. A quick edit of this file has solved my problem.

    Posted 7 years ago on Thursday January 17, 2013 | Permalink
  3. Thank you for posting that update.

    Posted 7 years ago on Tuesday January 22, 2013 | Permalink

This topic has been resolved and has been closed to new replies.