PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Page Unsecured Message

  1. Hello,

    We created a form to allow users to pay a monthly bill with the authorize.net addon but it is displaying an error message on the credit card field. We have an SSL certificate but the credit card field comes with a red banner saying "This page is unsecured. Do not enter a real credit card number. Use this field only for testing purposes." I have looked around the forum and googled any solutions but haven't found anything that could solve the problem, any help is appreciated, thanks.

    Form URL - https://www.crestwoodhousing.com/contact-us/payment/
    Gravity Forms version 1.6.5
    Wordpress version 3.4.1

    Posted 6 years ago on Thursday July 26, 2012 | Permalink
  2. David Peralty
    Administrator

    You have the following insecure item on the page:
    <link href="http://fonts.googleapis.com/css?family=Signika:300,400,600" rel="stylesheet" type="text/css" />

    Also, your Google Analytics might not be using HTTPS.

    Posted 6 years ago on Thursday July 26, 2012 | Permalink
  3. Yeah I saw that and removed it before I posted but it isn't the issue. I also just removed the analytics to test if that was issue but still have the error showing, anything else it might be?

    Posted 6 years ago on Thursday July 26, 2012 | Permalink
  4. We would like to go to production with the payment gateway. Can you help resolve the "This page is unsecured" error?
    Thanks, Chris.

    Posted 6 years ago on Friday July 27, 2012 | Permalink
  5. David Peralty
    Administrator

    I've messaged a developer regarding your issue.

    Posted 6 years ago on Friday July 27, 2012 | Permalink
  6. Any word from developer? We really need to get this finished.

    Thanks, Chris.

    Posted 6 years ago on Monday July 30, 2012 | Permalink
  7. Hello. Could you get me update if this is an issue with the plugin or the SSL?

    Thanks, Chris.

    Posted 6 years ago on Monday July 30, 2012 | Permalink
  8. Hi Fancymedia,

    Typically this a result of a unique server setup. If you can send me over your FTP information we can take a deeper look into your setup and see if we can't pin point the issue.

    In the meantime, you can use this hook to override the unsecure message:

    http://www.gravityhelp.com/documentation/page/Gform_is_ssl

    Posted 6 years ago on Monday July 30, 2012 | Permalink
  9. madebytincans
    Member

    I had the exact same issue. Thank you for posting the fix here. It worked perfect.

    Be nice not to have to use the hook, but I think the server my client is using probably falls under the "unique server setup" you mentioned.

    Posted 5 years ago on Friday May 31, 2013 | Permalink

This topic has been resolved and has been closed to new replies.