PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Please make GravityForms suppress Wordpress line spacing

  1. One of the biggest frustrations with GravityForms is that it doesn't deal with the stupid line spacing issue created by Wordpress. When you build an HTML Email, Wordpress inserts extra blank lines with every carriage return in the code. The result is that everything, including the formatting, stretches out in ridiculous ways with vast amounts of blank vertical space throughout the Email.

    ContactForm7 manages to deal with that problem by suppressing it. How the suppression happens is unclear, but they do it. That allows HTML Emails created using CF7 to actually look the way you intend. With GravityForms, the only way to avoid the spacing problem is to remove all line breaks in the code, butting all the tags up right next to each other in one massive block of text. This makes the code almost unreadable and very hard to edit.

    Here's a comparison of how the two Emails compare. The exact same code is used in ContactForm7 on the left and Gravity Forms on the right:

    This means that I often find myself using CF7 on client websites instead of GravityForms which in every other respect is the best forms plugin. Please, please address this so that I can rely on GravityForms for all client sites.

    Posted 9 years ago on Monday April 15, 2013 | Permalink
  2. It sounds like you mean in the email notification? If you want to prevent WordPress from adding paragraphs and line breaks, check the box under your notification textarea which says "Disable Auto-formatting" - that will prevent WordPress from adding any markup at all to your message. That will require that you add your own < br /> and <p> tags, but it will give you complete control over the HTML.

    Posted 9 years ago on Thursday April 18, 2013 | Permalink
  3. Awesome! Thanks so much!

    Posted 9 years ago on Thursday April 18, 2013 | Permalink