PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Subscriber failure when going through GF

  1. The contact form on my client's site is accepting and storing information in it, We are using GF Version 1.6.7 and the 1.7 MC addon on the live site, and 1.6.3 of the MC addon on one of the dev sites, since this thread seemed to suggest that a rollback might help, and I had gone back all the way to 1.5 at one point (which I had thought was working but apparently not):

    http://www.gravityhelp.com/forums/topic/mailchimp-not-getting-subscribers

    I thought it was a double opt-in issue, but the subscription isn't happening either with or without that checked. I installed the GF Logging Add-On that Chris H sent me, and this is the info that I am getting back:

    Transaction failed. Error 270 - "Recipes" is not a valid Interest Group for the list: ChefsBest Subscribers

    And based on the array dump in the logs, this is what is being sent:

    [GROUPINGS] => Array
    (
    [0] => Array
    (
    [name] => What news would you like to receive?
    [groups] => Recipes, tips, and news
    )
    )

    It looks to me as if it is treating the groups as a comma delimited list, when in fact the whole group is: "Recipes, tips, and news", so it is correct when it returns the error '"Recipes" is not a valid Interest Group', and maybe it should be enquoting the group.

    Any help is appreciated.

    Posted 7 years ago on Saturday October 6, 2012 | Permalink
  2. The issue has been noted previously and is due to the comma in the group name. Please see this: http://www.gravityhelp.com/forums/topic/mail-chimp-groups-length-of-name#post-75894

    Posted 7 years ago on Sunday October 7, 2012 | Permalink
  3. Is there a beta release that addresses the issue? And do you know what the eta of the fix is please? Thanks.

    Posted 7 years ago on Sunday October 7, 2012 | Permalink
  4. Please contact Dana at dana@rocketgenius.com and reference this topic so she knows what you are referring to. Also, because you have a developer license, you can use the priority support form if you like. Please reference this topic when you do so.

    Posted 7 years ago on Monday October 8, 2012 | Permalink
  5. I received your email and just sent you a version with the bug fix.

    Posted 7 years ago on Monday October 15, 2012 | Permalink
  6. Marketing Manager
    Member

    Dana, am I able to get a version with the bug fix as well? I'm having the same issue.

    Posted 7 years ago on Tuesday October 16, 2012 | Permalink
  7. tech4pub please contact Dana at dana@rocketgenius.com and reference this topic so she knows what you are referring to.

    Posted 7 years ago on Wednesday October 17, 2012 | Permalink
  8. tech4pub,

    I have emailed you the updated version.

    Posted 7 years ago on Wednesday October 17, 2012 | Permalink
  9. I don't know if I'm having the same issue, but I just installed Gravity Forms with the MailChimp add-on with multiple Groups (none have comma in the name), and though the form works collecting info into WordPress and with the double Opt-IN the off, the subscribers get added to MailChimp.

    However, when I turn Double Opt-in on, as MailChimp recommends, the opt-in email never gets sent and the thus the subscriber is never added to the MailCHimp list.

    I already contact MailChimp and they said I needed to contact Gravity Forms.

    Any suggestions?

    Thanks,
    Michael

    Posted 7 years ago on Wednesday October 24, 2012 | Permalink
  10. The email to confirm the subscription comes from Mailchimp. I wonder why that is not being sent when you have the "double opt-in" setting checked.

    If you would like to debug further, please send me an email at chris@rocketgenius.com - I have an alpha release of a logging add on which can help us debug this. Please be sure to include a link to this topic in your email so I know what we're talking about. Thank you.

    Posted 7 years ago on Thursday October 25, 2012 | Permalink