PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

There was a problem with your submission. Errors have been highlighted below.

  1. Hi Guys,

    We've been wrestling trying to integrate the Authorize.net plugin with a form too and ended up getting the same error repeatedly, which was something like:

    "There was a problem with your submission. Errors have been highlighted below."

    Gravity highlights:

    • Cardholder name
    • Card number
    • Expiration Date
    • Security Code

    Aside from the highlight, though, there's no other helpful information indicating why there was a problem.

    We tried a bunch of things and finally just output the response we were getting from Authorize.net and it showed that Phone was required.

    Since there's no way when setting up the form feed to map phone from the Gravity Form to Auth.net, I investigated on the Authorize.net end to see if you can indicate required fields through the Merchant interface and you can.

    Here's how we fixed the error:

    1. Login to the Authorize.net Merchant account
    2. Click on Account / Settings
    3. Under Transaction Submission Settings, click the Payment Form link.
    4. Click the form fields link. This will show you all of the fields "should be viewable, editable, or required when submitting a transaction using the Payment Form."
    5. Under the required column, uncheck any fields that aren't being passed over in the Gravity Auth.net feed. In our case, we had to uncheck Phone and all of the Shipping Address fields.
    6. Go back to your form and test again. Once the fields you're passing over from Gravity Forms (visible in the Feed you've setup under Forms/Authorize.net in the WP Dashboard) match the required fields in Auth.net, you should be fine.

    I hope this helps,
    Eric & the IvyCats

    Posted 7 years ago on Thursday March 1, 2012 | Permalink
  2. Hi, ivycat,

    Thank you for the info. We will take a look. Are you using v1.0 Beta 2?

    Posted 7 years ago on Thursday March 8, 2012 | Permalink
  3. Hey guys,

    I recently read this post tried what you said to do, however I was still unsuccessful. I noticed that I have required fields in the form that are not shown in the feed, dose that matter.

    I also mapped the fields in the feed with authorize.net and unchecked the required boxes and still get nothing.

    Posted 7 years ago on Thursday March 8, 2012 | Permalink
  4. I am struggling with making this work as well. I get an error message "There was an error processing your credit card. Please verify the information and try again." I tested the information above, but without positive results. Any help would be greatly appreciated. Thanks.

    Posted 7 years ago on Friday March 9, 2012 | Permalink
  5. Hi, folks,

    Can you help us out by turning on logging for Authorize.net? You can do this by going to the Forms --> Settings --> Authorize.net link at the top. Once there add "&debug=1" to the url in the browser. Once you do this, a Debugging Settings section will display. Set Logging to "Log all messages" and click on Save Settings. Once you have some transactions that have the problem, please send us the log file(s) generated. The log file will be in ...\wp-content\plugins\gravityformsauthorizenet . You can email them to dana@rocketgenius.com or alex@rocketgenius.com and include a link to this forum topic.

    Thank you!

    Posted 7 years ago on Friday March 9, 2012 | Permalink
  6. omeany2
    Member

    Had the same issue. Just turning on logging made it start working.

    Posted 7 years ago on Thursday March 29, 2012 | Permalink

This topic has been resolved and has been closed to new replies.