PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Warning Message after entering subscription

  1. HelmaP
    Member

    I just updated Gravity Forms and MailChimp Add-On on http://www.itheechhus.nl and after entering name and e-mailadres on the homepage I get the following warning message on the top of the page:

    Warning: array_keys() [function.array-keys]: The first argument should be an array in /www/i/t/h/itheechhus.nl/public_html/wp-content/plugins/gravityformsmailchimp/mailchimp.php on line 1410

    Warning: Invalid argument supplied for foreach() in /www/i/t/h/itheechhus.nl/public_html/wp-content/plugins/gravityformsmailchimp/mailchimp.php on line 1413

    Please help.

    Kind regards,
    Helma Paternostre

    Posted 10 years ago on Thursday January 19, 2012 | Permalink
  2. agelfand
    Member

    I have the same problem, and am likewise interested in knowing what caused it.

    I just upgraded to the latest mailchimp add on this morning.

    Posted 10 years ago on Thursday January 19, 2012 | Permalink
  3. swebb
    Member

    Add me to the list of people experiencing this problem.

    Posted 10 years ago on Thursday January 19, 2012 | Permalink
  4. swebb
    Member

    Does anyone know where I can find the previous version of the plugin (so I can revert back until a patch is released)?

    Posted 10 years ago on Thursday January 19, 2012 | Permalink
  5. swebb
    Member

    The problem appears to be on line 1408:

    $groupings = $feed["meta"]["groups"];

    I can't find a reference to $feed["meta"]["groups"] anywhere else in the file (or the other referenced files). Like an idiot, I blindly updated this plugin so I don't have the previous version of the code. I'm trying to find it somewhere, but I haven't had any luck yet. Anyone have any thoughts?

    Posted 10 years ago on Thursday January 19, 2012 | Permalink
  6. Does everything work with the exception of seeing the PHP warning? Or, does something not work, in addition to the display of the PHP warning?

    Posted 10 years ago on Friday January 20, 2012 | Permalink
  7. Do you see a message when debug mode is disabled in WordPress? These appear to be debug warnings, not errors. Test with debug mode disabled. You shouldn't run a live site in debug mode unless testing anyway. We'll take a look and see what is going on.

    Posted 10 years ago on Friday January 20, 2012 | Permalink
  8. swebb
    Member

    @Chris As far as I can tell, the warning is the only problem with 1.6 (compared to 1.5). As I've already requested, I would *love* a link to download 1.5 and revert back to a working plugin.

    @Carl Yes, WP_DEBUG has been set to false this entire time, and the warnings still appear after a form is submitted that is attached to MailChimp. Again, I would genuinely appreciate a link to the last working version of the plugin (1.5).

    Posted 10 years ago on Friday January 20, 2012 | Permalink
  9. I am looking at what is causing this issue. Please email me to alex@rocketgenius.com and I will be glad to send you our last working version.

    Posted 10 years ago on Friday January 20, 2012 | Permalink
  10. HelmaP
    Member

    Hi,

    I just updated Gravity Forms MailChimp Add-On to 1.6.1 and it seems to work now. :-)
    Thanks.

    Helma
    http://www.itheechhus.nl

    Posted 10 years ago on Monday January 23, 2012 | Permalink

This topic has been resolved and has been closed to new replies.