PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

WYSIWYG is not a function - Signature Add-On

  1. After updating to GF 1.6.4.1.1 (and possibly 1.6.4.1) the form that I have a signature field in no longer displays (it worked fine before).

    I am getting 'wysiwyg is not a function' error in Firebug console.

    When I remove the signature field, the form displays fine.

    The form can be seen at: http://indiechickscafe.com/test-contract/

    Is there an incompatibility with the Signature Add-On and 1.6.4.1?

    Thanks!

    Posted 7 years ago on Saturday May 5, 2012 | Permalink
  2. Hi. Anyone on this?

    Posted 7 years ago on Wednesday May 9, 2012 | Permalink
  3. David Peralty
    Administrator

    Can you try upgrading to the latest version and see if that fixes your issue?

    Posted 7 years ago on Wednesday May 9, 2012 | Permalink
  4. Hi David,

    I already have updated to the very latest - 1.6.4.2.1
    Still the same problem.
    Thanks much for the help

    Posted 7 years ago on Wednesday May 9, 2012 | Permalink
  5. David Peralty
    Administrator

    I think you might be having a contact form 7 or bbpress issue. The wysiwyg is referencing those two plugins. Can you disable them if you have them activated and see if that solves the issue.

    http://www.gravityhelp.com/documentation/page/Testing_for_a_Theme/Plugin_Conflict

    Posted 7 years ago on Wednesday May 9, 2012 | Permalink
  6. David Peralty
    Administrator

    Here is the spot where the error exists:

    {a("#comment,#topic_text,#reply_text,#message_content,#bbp_topic_content,#bbp_reply_content,.wpcf7-textarea").wysiwyg({controls:{bold:{visible:!0}

    As you can see it messes with a bunch of ID's including bbp_topic_content and bbp_reply_content and wpcf7-textarea. This exists in your header file.

    Posted 7 years ago on Wednesday May 9, 2012 | Permalink
  7. Hmmm...

    Neither bbPress, nor Contact Form 7 are installed on the site. Contact Form 7 has never been installed (I never use anything but Gravity Forms), and bbPress MAY have been installed long ago during development, but was never used and was uninstalled long ago.

    What you may be confusing as Contact Form 7 is actually CDN7, which is my JS load from Amazon CDN via W3 Total Cache.

    Which did lead me to disabling W3 Total Cache. And the problem went away. It looks like a minification problem.

    But I do not have any Gravity Form JS or CSS files in minification. So it must be another JS file that I AM minifying that works together with either GF or the Signature Add-On.

    I'm not seeing any obvious ones. Can you tell me which JS files the Signature Add-On uses?

    I'll keep hunting.

    Thanks David!

    Posted 7 years ago on Wednesday May 9, 2012 | Permalink
  8. David Peralty
    Administrator

    Signature Add-on uses adds its own JS file, and it uses JQuery. I haven't heard of minified JQuery causing such issues before though. I have heard about caching issues causing problems with JavaScript before though.

    As for the wysiwyg error, I double checked again using a Google search and looking at the code in your theme, and those calls exist on the page you sent me to, and Google does say they are from bbpress and Contact Form 7. So all I can do is shrug my shoulders in regards to those.

    Posted 7 years ago on Wednesday May 9, 2012 | Permalink
  9. David Peralty
    Administrator

    Also, just for your reference, it says script tipe instead of script type in the JS call that is creating the error. If you don't need that JS call, can you remove it? (The one that has the wysiwyg function call in it)

    Posted 7 years ago on Wednesday May 9, 2012 | Permalink
  10. The reason I believe it is a minification issue is that if I disable ONLY Minify in W3 Total Cache, the form works.

    I have 14 JS files being minified by W3 Total Cache, and none of them are from the GF plugin directory. And also JQuery is not in the 14. So this is a bit perplexing.
    I'm going to try to disable each JS one at a time in minify, and step through it to see if I can isolate it.

    Regarding the Contact Form 7 and bbPress.... that is very very strange, and I have no answers for it... :)

    Posted 7 years ago on Wednesday May 9, 2012 | Permalink
  11. Hi David,

    I found that this code
    {a("#comment,#topic_text,#reply_text,#message_content,#bbp_topic_content,#bbp_reply_content,.wpcf7-textarea").wysiwyg({controls:{bold:{visible:!0}
    was related to the plugin Rich Text Editor for Comments.

    I deleted the plugin, but still had the same issue.

    I then painstakingly eliminated the JS minification and found that it was related to a lightbox plugin (Lightbox Evolution) and JS conflict.

    Once I cleared that up, it worked. Thanks much for your patience and assistance.

    P.S. - W3 Total Cache may be more trouble than it's worth :)

    Posted 7 years ago on Wednesday May 9, 2012 | Permalink
  12. David Peralty
    Administrator

    I wish I could "like" your response. You spent a great deal of time troubleshooting and I really appreciate that. I'm glad you got it all figured out. I tip my hat to you good person.

    Posted 7 years ago on Thursday May 10, 2012 | Permalink