PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

1.6 rc4 Problems on Local Server

  1. Hi i am testing 1.6rc4 on my XAMPP local server and found some windows path related errors, probably this errors will not happen in a unix/linux server but i thought that reporting this errors could help ironing out any bugs still unsolved.

    On activation i got the following errors (only appeared once):

    Warning: opendir(D:\xampp\htdocs\xxxx/wp-content/uploads/gravity_forms/,D:\xampp\htdocs\xxxx/wp-content/uploads/gravity_forms/) [function.opendir]: The system cannot find the file specified. (code: 2) in D:\xampp\htdocs\xxxx\wp-content\plugins\gravityforms\common.php on line 65
    
    Warning: opendir(D:\xampp\htdocs\xxxx/wp-content/uploads/gravity_forms/) [function.opendir]: failed to open dir: No such file or directory in D:\xampp\htdocs\xxxx\wp-content\plugins\gravityforms\common.php on line 65

    Later i went to create a new form with no problem (did not try to save the form) then tried to activate some plugins but all i got is the error bellow, i deactivated all my plugins and still the same, every time i activate GF i get the error.

    Fatal error: Call to undefined method GFCommon::recursive_add_index_file() in D:\xampp\htdocs\xxxx\wp-content\plugins\gravityforms\gravityforms.php on line 403

    I checked the code and it is another path related error.

    Hope this helps.

    Posted 8 years ago on Wednesday October 5, 2011 | Permalink
  2. I also run XAMPP on Windows, but I am not getting these errors.
    The first error could be caused by a wrong value in your WP uploads folder setting. Can you upload files to your WP media library?
    The second error is very strange. It looks like a bad installation of Gravity Forms. Can you try deleting the gravityforms folder and re-copying it?

    Posted 8 years ago on Thursday October 6, 2011 | Permalink
  3. Hi Alex, the problem happens only in windows when GF is activated for the first time and it tries to creates the folder wp-content\uploads\gravity_forms, since the folder already exists in your setup you don't get the error.

    I checked the code and the problem seems to be in the copy_post_image function in forms_model.php.

    Hope this helps.

    Posted 8 years ago on Thursday October 6, 2011 | Permalink
  4. If there is an error with creating wp-content\uploads\gravity_forms then it is likely a file permission error. Check to make sure file permissions are set on wp-content\uploads to allow plugins to write and create in that folder.

    The other problem could be related.

    Posted 8 years ago on Thursday October 6, 2011 | Permalink
  5. Hello Carl, remember XAMPP works under windows not linux, so it can't be a permission error.
    It seems the problem is with the path separators, linux uses "/" and windows uses "\", when you look at the path string in the error message you can see it has both separartors.
    '
    D:\xampp\htdocs\xxxx/wp-content/uploads/gravity_forms/
    '

    Posted 8 years ago on Thursday October 6, 2011 | Permalink
  6. @signo,
    I think we have resolved this issue on our latest build (which hasn't been released yet). If you send me an email to alex@rocketgenius.com, I can send it over to you and see if it solves the problem.

    Posted 8 years ago on Friday October 7, 2011 | Permalink
  7. email sent.

    Posted 8 years ago on Friday October 7, 2011 | Permalink
  8. It looks like this also occurs when doing Multi-Site network activation of the main GF plugin

    Posted 8 years ago on Thursday October 13, 2011 | Permalink
  9. @omaruddin Please email Alex directly at alex@rocketgenius.com and provide as many details as possible as to A) what the issue is and B) how to replicate it so that he can look into it. Reference this forum post when doing so, that way he knows what your email is in reference to.

    Posted 8 years ago on Thursday October 13, 2011 | Permalink
  10. Carl - done :)

    Posted 8 years ago on Friday October 14, 2011 | Permalink