PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

1.6 Release Candidate 5 Product Field Duplication Bug

  1. I tested 1.6 RC4 and RC5 with an order form where I duplicated a standard product field multiple times. Each has a slightly different name, price and description for each. The fields are not required, however, when I go to preview and test the form, the duplicated fields are highlighted in red and indicate that I need to "Please enter a valid value" when I select next to go to the next page (this is a multiple page form, the fields in question are on page 2 of a 3 page form). But even when I filled out the fields with a numerical value of 1 (there is no range) they are still highlighted in red and I cannot continue. To resolve the problem, I need to delete the duplicated fields and recreate the fields separately (not duplicate it).

    This originally occurred in RC4. I upgraded to RC5 and was able to recreate the issue. I created a new product field. Duplicated it. Saved. Selected Preview and tried to proceed through the form leaving the non-required duplicated fields empty and got the same "Please enter a valid value" message. Entering a valid value does not help.

    I was using the latest version of Chrome on MacBook Pro running Lion OS X. The Javascript error console indicates no errors.

    Tested in the latest version of Firefox as well and obtained the same results. I tried making it required, saving and then unchecking required, but no luck there. I disabled quantity, but still get prompted to enter a valid value when there is no place to enter a value.

    I have been able to duplicate HTML sections without any problems.

    I'm running WordPress 3.21.

    Posted 8 years ago on Tuesday October 18, 2011 | Permalink
  2. Thank you for the information. I'll pass it along to the developers to see if we can recreate the problem.

    Posted 8 years ago on Tuesday October 18, 2011 | Permalink
  3. I was able to replicate and correct the issue. If you are interested in getting my latest version and helping us test it, please email me and I will send you the file.
    alex@rocketgenius.com

    Posted 8 years ago on Tuesday October 18, 2011 | Permalink