PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

1,600 export limit

  1. dotcom
    Member

    We have faced a limit of 1,600 entries being able to export in CSV from the database. Is there any way to lift this limit?

    GF v1.5.2.8

    Posted 10 years ago on Tuesday January 3, 2012 | Permalink
  2. dotcom
    Member

    Have temporarily fixed this by changing:
    $page_size = 50;
    in export.php

    Why does this occur? Is there now a higher limit in place?

    Posted 10 years ago on Tuesday January 3, 2012 | Permalink
  3. Sounds like a PHP memory issue. How much RAM is available to PHP and to WordPress?

    Here's an article on increasing the available RAM:
    http://www.nerdgrind.com/increase-wordpress-and-php-memory-limit/

    It could also be a timeout, which is also a PHP configuration issue.

    Posted 10 years ago on Thursday January 5, 2012 | Permalink
  4. dotcom
    Member

    The available RAM was set to 32MB for WordPress and 64MB for PHP.

    I've increased this to 256MB and 512MB respectively, reset the $page_size to 200 and it is exporting all the entries correctly now.

    Posted 10 years ago on Saturday January 7, 2012 | Permalink
  5. dotcom
    Member

    As a side note, maybe setting the default $page_size to 50 for gravity forms is a good move? It would help those will smaller RAM limits in place.

    If you are going to change it, you should probably run the script with various $page_size to find the optimal number.

    5,10,20,30,40,50,100,200,400

    Posted 10 years ago on Saturday January 7, 2012 | Permalink
  6. Thank you for the suggestion and we're happy you were able to resolve your problem. Thanks for the update.

    Posted 10 years ago on Monday January 9, 2012 | Permalink

This topic has been resolved and has been closed to new replies.