PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Adding fields in Form Editor is broken

  1. Hi,

    I'm unable to add fields in Form Editor.
    I can add a field if I deactivate a plug-in called "Choc Chip EU Cookie Plugin", however, I have the same plug-in on my test site and there are no conflicts.

    http://www.christiansenior.co.uk/talkin-shop/choc-chip-eu-cookie-wordpress-plugin

    My installation status is as follows:

    PHP Version 5.3.26
    MySQL Version 5.5.31
    WordPress Version 3.5.2
    Gravity Forms Version 1.7.6

    The (working) test site installation is:

    PHP Version 5.3.26
    MySQL Version 5.5.32
    WordPress Version 3.5.1
    Gravity Forms Version 1.7.5

    Any ideas of what I need to do to get the Form Editor to work again without disabling the cookie plug-in?

    Posted 6 years ago on Wednesday July 10, 2013 | Permalink
  2. Richard Vav
    Administrator

    Can you try enabling 'No-Conflict Mode' on the Gravity Forms general settings page.

    Posted 6 years ago on Wednesday July 10, 2013 | Permalink
  3. Yes, it's been enabled and the problem persists.

    Also - I was incorrect in saying that my test site is working OK. The plug-in is off there, too.

    What should I try next?

    Posted 6 years ago on Wednesday July 10, 2013 | Permalink
  4. Richard Vav
    Administrator

    Can you check the browsers developer tools to see if there are any javascript errors being reported.

    Posted 6 years ago on Wednesday July 10, 2013 | Permalink
  5. Hello Richard

    I received the following JS error:

    Uncaught SyntaxError: Unexpected token ILLEGAL tw-sack.min.js:1
    runResponse tw-sack.min.js:1
    xmlhttp.onreadystatechange tw-sack.min.js:1

    Also: when enabling the cookie plug-in (although I realise that this is not your area) I receive the error message: "The plugin generated 198 characters of unexpected output during activation. If you notice “headers already sent” messages, problems with syndication feeds or other issues, try deactivating or removing this plugin."

    Matt

    Posted 6 years ago on Thursday July 11, 2013 | Permalink
  6. Richard Vav
    Administrator

    Matt,

    I downloaded that cookie plugin and installed it on a localhost with WP 3.5.2 and Gravity Forms 1.7.6 and I was able to edit fields just fine. If you disable all other plugins so you only have the two running does that make any difference, I am wondering if there is a third plugin at play here.

    Regards
    Richard

    Posted 6 years ago on Thursday July 11, 2013 | Permalink
  7. Cheers Richard

    I'm going to try a new cookie plug-in. Only activating Gravity Forms and the EU plug-in is still causing errors.

    I may be back if I cannot get an alternative cookie plug-in to work - otherwise, please consider this thread resolved.

    Matt

    Posted 6 years ago on Thursday July 11, 2013 | Permalink
  8. Richard Vav
    Administrator

    Matt,

    If you run into further trouble please use our new request support form.

    Regards,
    Richard

    Posted 6 years ago on Thursday July 11, 2013 | Permalink

This topic has been resolved and has been closed to new replies.