PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Address field City field is not translated correctly

  1. I updated to Gravity Forms 1.7.2 today in multiple Dutch Wordpress installations.
    Adding an address-field has a strange result.
    Setting the default country to the Netherlands doesn't fix it.
    The field that was called "Plaats" before the update is now called ZIP / Postal Code.
    See the added screenshot:
    https://dl.dropboxusercontent.com/u/669331/Screen%20Shot%202013-05-12%20at%2010.36.55.png

    The *.po seems to have the right translation but it doesn't seem to get loaded.

    Any advise?

    Coen Meerbeek

    Posted 6 years ago on Sunday May 12, 2013 | Permalink
  2. I can confirm the translation error; Plaats is now ZIP/Postal code.

    Posted 6 years ago on Tuesday May 28, 2013 | Permalink
  3. David Peralty
    Administrator

    I'll let our development team know. Thanks.

    Posted 6 years ago on Tuesday May 28, 2013 | Permalink
  4. Vivienne
    Member

    I am having the same problem and will be following this thread. Any help would be appreciated.
    PS. The upgrade to 1.7.5 did not fix this.

    Posted 6 years ago on Sunday June 9, 2013 | Permalink
  5. I am having the same problem since 1.7.2. I've edited the language file, but that doesn't solve the problem.

    Posted 6 years ago on Monday June 10, 2013 | Permalink
  6. marc93
    Member

    Can this be fixed as soon as possible, for Dutch forms the address field is totally useless right now because of the wrong translation. Seems to me that it is a small and easy to fix error.

    Posted 6 years ago on Friday June 14, 2013 | Permalink
  7. The problem is that we have upper cased the "Zip" string (changed to "ZIP"), since that is the correct spelling. So, what you will need to do is update your .po file from the provided .pot file and then add the translation to the upper case "ZIP" string.

    Posted 6 years ago on Friday June 14, 2013 | Permalink
  8. marc93
    Member

    The problem is not the translation of ZIP/code. The problem is that two fields have the same label. The 'ZIP code' field is translated as 'Postcode' which is correct. The 'city' field is translated as 'ZIP code' and this must be 'Plaats'. You're suggesting that there are now two strings in the .po file with the label 'ZIP/code' so I'm still confused. I also don't know how to open the .pot file. I can't do that with the po-edit app on my mac.

    Posted 6 years ago on Tuesday June 18, 2013 | Permalink
  9. Vivienne
    Member

    Just upgraded to 1.7.6, but still 'City' ('Plaats' in Dutch) has the 'ZIP / Postal Code' label :-(

    Posted 6 years ago on Wednesday June 26, 2013 | Permalink
  10. leono77
    Member

    Please Gravity Team.. 1.7.6. > four updates and no fix? This is a pretty easy bug to fix for the developers. Please fix it. I had a client who was not too happy about it. I changed it in the common.php file for now...

    Posted 6 years ago on Friday June 28, 2013 | Permalink
  11. David Peralty
    Administrator

    I responded in the other thread, but the same thing applies. Please fix the translation and send it back to us for distribution. We rely on our community to provide proper translation files. Please don't change common.php.

    All my best!

    Posted 6 years ago on Friday June 28, 2013 | Permalink
  12. leono77
    Member

    Hi, Thank you, and i know, but strangly it IS correct in the Dutch .po file. Version 1.6.x was correct with the same .po file downloaded from this site. I Did not try the .pot file though.

    http://www.goedhartreklame.nl/img/schermproef_911.png

    Posted 6 years ago on Friday June 28, 2013 | Permalink
  13. David Peralty
    Administrator

    I've sent another message to our developers about this. Hopefully, we can get this resolved soon.

    Posted 6 years ago on Friday June 28, 2013 | Permalink
  14. Vivienne
    Member

    The screenshot added by leono77 shows the old way of writing 'ZIP' (using lowercase letters), so that's probably the issue there. The thing is: why do we have to translate 'Zip / postal code' to 'plaats' (which is 'city' in English) at all? It's an incorrect translation.

    Posted 6 years ago on Monday July 1, 2013 | Permalink
  15. I have updated my .po with the new POT and can confirm the field names are incorrect in the POT file. I had to translate the string "ZIP / Postal Code" to "Plaats" to make it show up correctly.

    I makes me think something is indeed not set correctly for $adressTypes in commons.php

    Update: could it be that the International settings don't use the "zip_before_city" format?

    Posted 6 years ago on Tuesday July 2, 2013 | Permalink
  16. David Peralty
    Administrator

    So we have a fix for this in an unreleased version, if you could e-mail me at peralty@rocketgenius.com, I can send it to you to test. Please make sure you put in why you are e-mailing me in your message.

    Posted 6 years ago on Tuesday July 2, 2013 | Permalink

This topic has been resolved and has been closed to new replies.