PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Address field not showing in Firefox

  1. I'm having a problem with the address fields showing in firefox. When you view the form, that field is just blank and does not show. Any ideas? I deleted all other fields so it would be easy to find.

    Here is a link to the form : http://www.kenstanton.net/wp-beta/?page_id=143

    Thank you in advance!

    Posted 9 years ago on Friday April 8, 2011 | Permalink
  2. Upon a little more investigation. If you set CSS output to "no", the fields show up, but are not formatting properly. Can you tell me what to do to get it to view properly? Thank you!

    Posted 9 years ago on Friday April 8, 2011 | Permalink
  3. It's not the form CSS output that's the problem. It's coming from your theme stylesheet. If I disable the style.css file from your theme, the default form formatting works just fine.

    screenshot: http://j.mp/hvDx95

    You need to dig around your style.css file and see what might be causing the conflict. If I find it, I'll let you know.

    Posted 9 years ago on Friday April 8, 2011 | Permalink
  4. Thank you so much for your help. I really appreciate it!

    Posted 9 years ago on Friday April 8, 2011 | Permalink
  5. I'm not sure yet what's causing it.. most likely a height value set on list items in your stylesheet. This should work for now though. Try adding this to the end of your theme stylesheet.

    [css]
    body .gform_wrapper .ginput_complex {
        overflow: visible;
    }
    Posted 9 years ago on Friday April 8, 2011 | Permalink
  6. That helped a little, but it is still very flaky. The main address field does not show, it begins with the address line 2 field. I can't find anything in the stylesheet, but I am definitely not a css guru.

    Posted 9 years ago on Friday April 8, 2011 | Permalink
  7. Try adding this as well.

    [css]
    body .gform_wrapper .ginput_complex .ginput_left,
    body .gform_wrapper .ginput_complex .ginput_right,
    body .gform_wrapper .ginput_complex .ginput_full {
        overflow: visible
    }
    
    body #content .gform_wrapper ul {
    	margin:0
    }

    works for me.

    screenshot: http://d.pr/3cvZ

    Posted 9 years ago on Friday April 8, 2011 | Permalink