PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Address Line 2 is now required? How can I make it optional?

  1. cwd
    Member

    according to several topics on the forum here (http://www.gravityhelp.com/forums/topic/setting-required-fields-in-advanced-fields and others) I don't think address line 2 is supposed to be required but as of 1.6.9 and 1.6.10 it appears to be required. I believe I was using 1.6.6 and everything was fun but now it is behaving oddly.

    http://img821.imageshack.us/img821/2093/pictuream.png

    Posted 9 years ago on Thursday December 13, 2012 | Permalink
  2. arebee02
    Member

    Hi there,

    Did you find a solution to this? Same thing happening to me....

    Posted 9 years ago on Wednesday December 19, 2012 | Permalink
  3. cwd
    Member

    I did not. It would be nice if we could get one of the developers to look into it.... Maybe we should submit this to Priority Support?

    Posted 9 years ago on Wednesday December 19, 2012 | Permalink
  4. This was not my experience. I submitted a form with an address field required, but left the address line 2 blank, and it submitted fine. Here is a screenshot showing the validation error from a blank submission, and then how I finally submitted the form (without an address line 2.)

    http://minus.com/lfNw2fFrUE5vE
    (what you see there is what was successfully submitted after I took the screenshot)

    I am using 1.6.10.1

    Posted 9 years ago on Wednesday December 19, 2012 | Permalink
  5. David Peralty

    @cwd, in the picture you posted, the city was written in Address Line 2 and nothing was in State.

    Posted 9 years ago on Wednesday December 19, 2012 | Permalink