PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

admin-ajax.php server error in dashboard

  1. wesleymusgrove
    Member

    I have a theme conflict between Gravity Forms and the Gantry Theme Framework for Wordpress. When both are activated, I cannot successfully complete any AJAX driven edits or saves in the WP admin dashboard, like making "Quick Edits" to a Page or adding new Pages to an existing Menu. Also I am unable to save any changes I make to the page layout regarding widgets, because they too are saved via AJAX.

    Specifically, when I try to do these simple AJAX saves in the WP admin dashboard, I see this error in the Firebug console:
    POST to http://example.com/wp-admin/admin-ajax.php 500 (Internal Server Error) at load-scripts.php:4

    I have isolated this issue to when both Gravity and Gantry are activated. It appears to be a javascript enqueue related error, but i'm not sure where to make the changes talked about in the following articles:
    http://pippinsplugins.com/loading-scripts-correctly-in-the-wordpress-admin/
    http://www.prelovac.com/vladimir/best-practice-for-adding-javascript-code-to-wordpress-plugin

    I'm about 97% finished theming using Gantry, so deactivating the theme and keeping Gravity Forms isn't really an option at this point. If possible I'd like to keep both activated and find a workaround that will prevent the conflict from happening in the admin backend.

    Any help or advice would be much appreciated!

    Thanks,
    Wesley

    Posted 6 years ago on Thursday November 22, 2012 | Permalink
  2. David Peralty
    Administrator

    Under Forms -> Settings do you have No-Conflict Mode On or Off?

    Posted 6 years ago on Thursday November 22, 2012 | Permalink
  3. wesleymusgrove
    Member

    David,

    Thanks for the quick reply. I have No-Conflict Mode turned On so that it will not load extraneous scripts and styles. When I installed Gravity Forms initially, No-Conflict Mode was Off by default. I also had my Gantry Theme activated while installing/activating Gravity Forms. When I activated Gravity Forms, I got the white screen of death in the WP admin dashboard. I had to manually delete the Gravity Forms plugin directory, deactivate the Gantry theme, activate the Twenty Eleven theme, and THEN re-install/activate Gravity Forms and turn No-Conflict Mode On.

    Though the second time I didn't get a white screen of death when I installed/activated Gravity Forms, there still seems to be a conflict when I activate my Gantry theme after activating Gravity, as mentioned in the original post.

    I appreciate your help and Happy Thanksgiving!
    Wesley

    Posted 6 years ago on Thursday November 22, 2012 | Permalink
  4. It might be worth checking to see if you may need to increase your available PHP Memory. You can find out how to do that here:
    http://www.nerdgrind.com/increase-wordpress-and-php-memory-limit/

    Let me know how that goes.

    Posted 6 years ago on Monday November 26, 2012 | Permalink