PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Admin / Backend Slowness Issue

  1. tracedef
    Member

    Hiya,

    We're using Version 1.5.beta3.3 on two different multisite installs using 3.03 on the same server. Both installs use virtually identical plugins but one install takes quite a bit longer to load any page in the admin screen / dashboard for root site, which is the only site on the install that uses gforms. It probably takes an extra 3 to 7 second per page, which may not be a whole lot but it feels like each page is hanging when we've just come from the install that is not having issues with admin screen page load times that are 1 to 2 seconds.

    The issue no longer occurs when gforms is disabled or when we go to the backend of any other sites on the problem install as they do not use gforms.

    We've disabled every plugin on the install including deleting all mu-plugins plugins and the issue still occurs with gforms being the only plugin that is activated. We've also tried enabling a different theme for the site that is affected to no avail.

    So at the end of the day we have two very, very similar installs using the same hardware but one has an issue and the other does not.

    Given the troubleshooting / isolation we've already done, not sure what else we can do, but wanted to give a heads up in case other experience similar issues.

    Not sure if issue is related to these or not, but we are not running backup buddy:

    http://forum.gravityhelp.com/topic/back-end-slowness#post-8948
    http://forum.gravityhelp.com/topic/142-slow-and-buggy

    Posted 10 years ago on Thursday December 23, 2010 | Permalink
  2. The issue with backend slowness in those other threads was related to it checking for updates too regularly. Update checking is now cached and doesn't happen as frequently so it doesn't cause slowdown anymore.

    If you have 2 identical installs with one running slow and the other running fine then it could be something related to server or database performance rather than WordPress/plugin performance. It could be a memory issue on the server that only occurs with GF activated because of the increased need for memory in that situation.

    Posted 10 years ago on Thursday December 23, 2010 | Permalink
  3. tracedef
    Member

    @Carl. To speak to memory, here’s what I dug up. Regarding memory, we’re usually using around 12mb, the max usage for the past 24 hours has been 32 mb and there are 128mb allocated for the WP limit. The install with no issues has hundreds of sites on it and the install with issues has 5 or so sites on it…. We’re on a server much bigger than we need so resources shouldn’t be an issue on a macro level at least.

    I did just remember that I added 3 more forms last night, so that seems to be the trigger or at least the only change that has been made that is lining up when the issue started, we have about 6 forms total on that install.

    I was wondering if clearing the db of all gforms data might help, so we used the Gforms delete function to erase all data, which temporarily fixes the issue because gforms is turned off during this process. Once we turn gforms back on, even with no data, the extended admin load times return.

    Also, as I mentioned previously, only the root site on the install has the issue as it is the only site that uses gforms, but if we turn on gforms on other sites on the install that have never used gforms before, they immediately begin exhibiting the issue …

    We also installed the non-beta version to see if that had any effect at all but the load times were still occurring.

    We’ve ruled out conflicts with other plugins, so I’m not sure where that leaves us. I realize there’s only much you can do, hopefully what I’ve given you helps and if we come up with something we’ll report back, any other ideas or feedback appreciated. Might have to bring somebody who’s more of a database pro to take a peek, I’m thinking that is where the issue must be?

    Posted 10 years ago on Friday December 24, 2010 | Permalink
  4. likomawatermark
    Member

    I'm having the same issue, but only with the WP Dashboard. If GF is activated, the Dashboard can take 10 seconds to load. Even if I remove it from view with the Screen Options. If I deactivate the plugin, the Dashboard loads quickly.

    I'm on a zippy server where everything else (WP backend, site) moves along quickly. Any thoughts? I'm not giving up GF, but I like my Dashboard, too!

    Posted 10 years ago on Thursday March 24, 2011 | Permalink
  5. @likomawatermark How many Forms and Entries do you have? It could be Dashboard Widget related. Are you running the latest 1.5 also?

    Posted 10 years ago on Thursday March 24, 2011 | Permalink
  6. likomawatermark
    Member

    Just one form, 20 entries (559 views). Just upgraded to 1.5 and no improvement. Maybe a conflict with another plugin? Hmm, I just checked on other sites where I have GF running and the dashboard isn't slow. Here's what I'm running:

    http://www.likoma.com/plugins-used/

    Posted 10 years ago on Thursday March 24, 2011 | Permalink
  7. It's possible it's another plugin. You are running just about 30 plugins which is quite a lot. You could try deactivating all and just test with Gravity Forms and then enable them one by one. WordPress will slow down the more plugins you run and the more complex a plugin is. Things like available server memory, CPU, MySQL memory and MySQL cpu usage will come into play.

    Posted 10 years ago on Thursday March 24, 2011 | Permalink
  8. likomawatermark
    Member

    Thanks, Carl. I'm running YSlow to see what's up and, not surprisingly (since you guys actually support your plugin!), GF isn't the speed culprit. More like the oldies I have (exec-php) and biggies (Google Analyticator).

    Posted 10 years ago on Thursday March 24, 2011 | Permalink