PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Administrator can see File uploads. Editor getting 404

  1. HI All

    I am having an issue where an editor level user is getting a 404 when trying to view an image. I'm an admin (super admin on network) and I am able to see the file at the URL.

    We are on a network install, but the plugin is installed on a per site basis.

    Everything else about GF appears to be working but this.

    We are not using any special permissions plugins. Straight forward WP user levels.

    We did give editors access via this hook

    function add_grav_forms(){
        $role = get_role('editor');
        $role->add_cap('gform_full_access');
    }
    add_action('admin_init','add_grav_forms');

    thanks for all help you'll be giving :) (hopefully!)

    Posted 6 years ago on Monday October 1, 2012 | Permalink
  2. The file at the public URL should be accessible to anyone, logged in or not, any level, if it's in the wp-content/uploads/* folder. Where are they clicking to get that 404? In the entry? So the file which is uploaded to the wp_content/uploads/gravity_forms/* folder? Those are accessible to the world too, logged in or not.

    Here is a file which was uploaded via a Gravity Form:
    http://gravity.chrishajer.com/wp-content/uploads/gravity_forms/47-af54362ceeff1f70c4a3070370fa701c/2012/08/balloons.jpg

    Here it is in the wp-content/uploads folder (media library, attached to a post, in all the various sizes from the media settings):
    original
    150x150
    300x241
    585x288
    373x300

    You should be able to load every one of those images without being logged in to my site at all.

    Posted 6 years ago on Tuesday October 2, 2012 | Permalink
  3. After I made that post yesterday the person having issues went to a different machine and was able to see the picture.... so I'm thinking it's something on his machine.

    Thanks for the reply. I didn't think there were any limitations to linking to the file like that.

    Thanks

    Posted 6 years ago on Tuesday October 2, 2012 | Permalink
  4. There are no limitations like that. Sounds like it probably was something on the user's computer. Thank you for the update.

    Posted 6 years ago on Tuesday October 2, 2012 | Permalink

This topic has been resolved and has been closed to new replies.