PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Advanced Field "website" question

  1. Hello, I am sure this is just so simple and I'm not seeing it.....
    My form uses the advanced field - 'Website' - which prepopulates with http://
    Once the visitor completes that field with the url and clicks the submit button they are taken to the home page and not the thank you message. If the visitor doesn't complete the field with the url then they are taken to a Page Not Found page. If the field doesn't prepopulate with the http:// then the form works fine. What am I not getting or doing wrong? Thank you.

    Posted 8 years ago on Tuesday September 6, 2011 | Permalink
  2. What are your confirmation settings?

    Can you post a link to your page with the form?

    Posted 8 years ago on Tuesday September 6, 2011 | Permalink
  3. Thanks for your response, Chris! The confirmation setting is: Text/Insert Form Field/Disable Auto Formatting is unchecked. Here is the link: http://law2sm.com/test/learn-more-chat-session/
    Thanks!

    Posted 8 years ago on Tuesday September 6, 2011 | Permalink
  4. There's something weird going on in your server or installation, not Gravity Forms. I submitted the form a few times from Chrome and was sent to a 404 in every case.

    In Firefox, the page would not even load as it was already a 404. That was before submitting the form, just trying to load your URL.

    Also, the 'test' in the url is sometimes being rewritten to 'testimonials', possible due to Apache mod_speling.

    Are there two sites here, one in /test and one in the root?

    See the results of trying to load this page in Firefox (before ever trying to submit it.)
    http://minus.com/micw4gm25

    Something is odd with your setup. Can you explain more about it?

    Posted 8 years ago on Tuesday September 6, 2011 | Permalink
  5. Thank you for such a quick reply, Chris! I would have replied sooner, but did not see the reply in my inbox. So following are replies to your email. Please let me know if you need further information. I appreciate your help!

    You: There's something weird going on in your server or installation, not Gravity Forms. I submitted the form a few times from Chrome and was sent to a 404 in every case.

    Me: Yes...that is correct if you leave the Website field prepopulated with http://. If you take out the http:// from that field then it works fine, and the page goes to the thank you message. If a visitor completes that field with his or her url and clicks the submit button they are taken to the home page and not the thank you message. If the field doesn't prepopulate with the http:// then the form works fine.

    You: In Firefox, the page would not even load as it was already a 404. That was before submitting the form, just trying to load your URL.

    Me: It works for me.

    You: Also, the 'test' in the url is sometimes being rewritten to 'testimonials', possible due to Apache mod_speling.

    Me: Thank you. I'll look into this.

    You: Are there two sites here, one in /test and one in the root?

    Me: Yes - I worked on the site before launch in the test directory and then uploaded in to the root directory when we went live. I deleted the test directory after making the site live, but reinstalled it to work on the issues I was having with the form.

    You: See the results of trying to load this page in Firefox (before ever trying to submit it.)
    http://minus.com/micw4gm25

    Me: Thank you for this information. But if I am seeing the site...what does this mean?

    You: Something is odd with your setup. Can you explain more about it?

    Me: This is a Genesis Site, Corporate Child Theme. I have a no-follow robot file on the test directory and put in a print.css file on the root...other than that everything is pretty much standard.

    Posted 8 years ago on Wednesday September 7, 2011 | Permalink
  6. There is still something goofy going on with the site. Is it possible when you copied the files from the test folder to the root, or from the root back to the test, that the .htaccess file got messed up (or not changed relative to the current directory) or that the url settings for the site are not correct in the Option page of the admin?

    Can you access the permalinks page in your wp-admin to just 'flush' the rules? You might have to save to ensure that a new .htaccess file is written.

    I think it will be much easier to debug if you have just one site installed as there is some weird crossover happening. I never saw the confirmation message, not matter what I submitted, and I had different experiences in different browsers, and different than yours as well. Something goofy is going on with the site(s) or server, but it's not related to Gravity Forms.

    Can you check at least 2 things:
    The WordPress address (URL) and Website address (URL) in your general options page:

    http://law2sm.com/test/wp-admin/options-general.php
    and
    http://law2sm.com/wp-admin/options-general.php

    And also, visit the permalinks setting page to ensure the rewrite rules are flushed:

    http://law2sm.com/test/wp-admin/options-permalink.php
    and
    http://law2sm.com/wp-admin/options-permalink.php

    Click "save changes" on those pages.

    Or, if you can, reduce down to just one site in the root and we can fix the problem there.

    Posted 8 years ago on Wednesday September 7, 2011 | Permalink
  7. Thanks, Chris. I will delete the test site so we can work on the root only. So I started over. I deleted the plugin. I also deleted the gravity forms files and directory from the uploads directory.
    And, deleted the the rg_form tables from the database and the code from the usermeta line under wp-capabilities. There are rg_form entries under wp-options and am not sure if those should also be deleted or if they can stay. I will look at another site I have that doesn't use gforms to see if it is something that comes inherit in Genesis. Anyway I will let you know when I have things reset so you can take another look. Thanks again! Rose PS I looked at the general and permalinks settings and everything looked good there. I use the custom entry under permalinks with /%postname%/.

    Posted 8 years ago on Wednesday September 7, 2011 | Permalink
  8. Ok...test site deleted...here is the link to the page on which the form appears http://law2sm.com/learn-more-chat-session/
    So when you fill out the form with http:// deleted from the Website field the form submits just fine, otherwise if you leave the http:// in by itself or fill it out completely with a website url the form will not submit...just goes back to the same page. Any suggestions? Thanks!

    Posted 8 years ago on Thursday September 8, 2011 | Permalink
  9. OK, we're back to square one. Got it. I was able to replicate the problem you were having (if there is anything at all in the website field, the form refreshes and comes back blank. Delete anything in the website field and it submits fine.)

    I submitted the form 4 times. I only showed the confirmation once. I am curious if the other entries made it through though. Do you have entries 4 entries from chris@rocketgenius.com ?

    If you submit this same form from the preview, does it act the same way?

    If you remove the website field, does the form submit as expected?

    Are no fields required on that form? I clicked submit with no data, and the form just refreshed the page, with no confirmation message either.

    Posted 8 years ago on Thursday September 8, 2011 | Permalink
  10. Thank you for your continued help with this! Please let me know if you need further info.

    You: OK, we're back to square one. Got it. I was able to replicate the problem you were having (if there is anything at all in the website field, the form refreshes and comes back blank. Delete anything in the website field and it submits fine.)

    Me: Yes, this is correct.

    You: I submitted the form 4 times. I only showed the confirmation once. I am curious if the other entries made it through though. Do you have entries 4 entries from chris@rocketgenius.com ?

    Me: I have not received any notifications...even from those forms that I submitted on test. I'm not totally sure I have it set up correctly. I have my email address in as the one receiving notifications.

    You: If you submit this same form from the preview, does it act the same way?

    Me: Yes

    You: If you remove the website field, does the form submit as expected?

    Me: Yes

    You: Are no fields required on that form? I clicked submit with no data, and the form just refreshed the page, with no confirmation message either.

    Me: There will be.

    Posted 8 years ago on Thursday September 8, 2011 | Permalink
  11. Rather than just notifications, if you log in to your wp-admin, are there any entries there? Email notifications don't always arrive reliably, at least not when starting out.

    If you submit from the preview, it still fails. Correct? And if you remove the website field, it will work fine?

    Can you make one field required (maybe name or email) so I can see what a bad validation would return?

    Also, can you try recreating the form with the same exact fields and see if that one works?

    Posted 8 years ago on Thursday September 8, 2011 | Permalink
  12. Ok, thanks, Chris. Here you go...appreciate your stickwithitness!

    You: Rather than just notifications, if you log in to your wp-admin, are there any entries there? Email notifications don't always arrive reliably, at least not when starting out.

    Me: The information in the submitted form does turn up in entries and is now turning up somewhat in the inbox.

    You: If you submit from the preview, it still fails. Correct? And if you remove the website field, it will work fine?

    Me: Yes, from preview, the form will not submit with the pre-populated info, but will with it deleted.

    You: Can you make one field required (maybe name or email) so I can see what a bad validation would return?

    Me: This is done.

    You: Also, can you try recreating the form with the same exact fields and see if that one works?

    Me: I have the form the way we want it (except maybe a field or two more may be required when all is said and done).

    The link is http://law2sm.com/learn-more-chat-session/

    Posted 8 years ago on Friday September 9, 2011 | Permalink
  13. The information in the submitted form is making it into the entries, but there is no confirmation message shown? That's the bottom line at this point?

    I tried submitting the form with no data entered, and there was no validation failure message. Should there have been? It looks like there are 4 required fields there, but submitting the form did not show any validation failures.

    When I delete all the website fields, and submit with no data entered, the form comes back with validation errors. It's like something on the server is discarding the request when there is a link in the POST submission. Maybe overly aggressive mod_security or other security module for Apache?

    Email notifications are a whole other topic to be addressed separately. Check the entries in the wp-admin to know for certain if the entry was submitted.

    There's something very unusual and uncommon going on with your installation.

    Posted 8 years ago on Monday September 12, 2011 | Permalink
  14. Thank you for your response, Chris.

    You: The information in the submitted form is making it into the entries, but there is no confirmation message shown? That's the bottom line at this point?

    Me: No that's not it. The bottom line is that if there is an entry in the website, linked in or twitter fields the form does not submit.

    You: I tried submitting the form with no data entered, and there was no validation failure message. Should there have been? It looks like there are 4 required fields there, but submitting the form did not show any validation failures.

    Me: The reason the you didn't receive validation failure is because the website, linked in and twitter fields are prepopulated with info...if you delete that info and then submit without anything you will receive validation error for required fields. In other words the validation failure works on the required field if the website, linked in and twitter fields are not filled in at all.

    You: When I delete all the website fields, and submit with no data entered, the form comes back with validation errors. It's like something on the server is discarding the request when there is a link in the POST submission. Maybe overly aggressive mod_security or other security module for Apache?

    Me. Yes, that is correct. What exactly do I need to discuss with my host. I am using West Host. I am hoping to get this resolved soon. Thank you.

    Posted 8 years ago on Tuesday September 13, 2011 | Permalink
  15. I think I would ask them why a form submission with http:// (or https://) in the content would fail, but without it the form submission succeeds.

    I hope to get it resolved soon too.

    Posted 8 years ago on Tuesday September 13, 2011 | Permalink
  16. I have just spent a day-and-half with a similar problem--just moved a site from dev & testing running locally on WAMP to the production server on the web, and if I use the predefined "Website" field on the live site, and the user does not fill in the website address (and leaves it as "http://" with nothing else, the form clears but no data is entered into the Gravity Forms database. You are returned to the form and the thank-you page is NOT displayed.

    If, OTOH, you blank out the field, it saves just fine. If you enter data into the field and keep the http://, it doesn't save either. I'm just about to test things be using a "regular" text field.

    Posted 8 years ago on Wednesday March 7, 2012 | Permalink
  17. hubrik
    Member

    I'm not sure if this is the same issue I'm having - when I prepopulate a form (using the URL &field=value etc) and include an email or www address in the url (to populate a www or email field) the form does NOT submit correctly... no data is saved and no notification email is sent.

    When I remove the email= and www= fields from the Url and enter them manually the system works FINE.

    Interestingly, if I load the page with &www=blah.com&email=test the system works - i.e. this suggests it might be the "%2F" (/) %26 (@) or %3A (:) that's causing the problem.

    So:
    http://www.perfectcouples.com/nominate/?email=test%40gmail.com&www=http%3A%2F%2Fwww.mywedding.com
    DOES NOT WORK

    but
    http://www.perfectcouples.com/nominate/?email=testgmail.com&www=httpwww.mywedding.com
    DOES WORK but of course I have to edit the email and www addresses in the form.

    This is an outstanding bug as far as I can tell.

    Posted 8 years ago on Thursday April 5, 2012 | Permalink