PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

AJAX disabled

  1. Robsticles


    I've read the thread about themeforest themes causing issues with AJAX, but I think my issue is slightly different. I have a themeforest theme, which worked fine with AJAX enabled, but suddenly AJAX has stopped functioning. The forms now work as if AJAX is disabled and I can't find the issue.

    I've tested with all plug-ins disabled, any additional JS scripts have been removed. Funnily enough it does work on my local installation with a current version of the theme, Gravity Forms and an imported database.

    Here's a link to one of the forms:

    I'm not quite sure whether it was a theme update, plugin update or something else which triggered the issue.

    Any ideas what it could be?

    Thanks, Rob

    Posted 9 years ago on Monday September 24, 2012 | Permalink
  2. David Peralty

    I see your theme is pushing Gravity Form scripts to the footer instead of the header. This could be causing issues. Beyond that, we usually have people try the following steps to isolate the issue:

    Hope that helps.

    Posted 9 years ago on Monday September 24, 2012 | Permalink
  3. Robsticles

    Hi David,

    Ok, I've tested with all plugins disabled and also had the theme developers take a look. They said when the form is submitted they get this error:

    JSON.parse: bad control character in string literal
    You can disable/enable break notifications in panel's tab menu.

    I've also tested with all plugins disabled in twenty ten. Still no AJAX.

    Posted 9 years ago on Tuesday September 25, 2012 | Permalink
  4. Robsticles

    Hello again,

    Has anyone had a chance to take a closer look?

    Posted 9 years ago on Wednesday September 26, 2012 | Permalink
  5. Robsticles

    Coming up to 2 days now without a response... I'm starting to feel awfully lonely in here by myself :S

    Posted 9 years ago on Thursday September 27, 2012 | Permalink
  6. Hello Rob. Because you have a developer license, you have access to Priority Support. You can use that, but I will also flag this for David to take another look at it.

    If you have embedded the form with the shortcode, can you go back to the page or post and ensure that the shortcode still has ajax="true" in it? If you are using the function call, we'll have to make sure that is accurate as well. That is much less likely to be changed though.

    Posted 9 years ago on Thursday September 27, 2012 | Permalink
  7. Robsticles

    Hi Chris,

    Thanks for getting back to me.

    The shortcodes for my forms haven't changed. The only reason I noticed it was because I started seeing a higher number of page views in Google Analytics than normal. The shortcodes I'm using look like this:

    [gravityform id="4" name="Skilled Visa Assessment" title="false" description="false" ajax="true"]

    Posted 9 years ago on Thursday September 27, 2012 | Permalink