PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

AJAX submit shows webpage again below the form WP 3.5

  1. Hey when I submit my form it creates the current webpage again below the form :/

    Have tried disabling all plugins except for GF and using the Twenty Ten theme

    If I turn off AJAX in the form and press submit, the page refreshes but doesn't show any error messages.

    Any help would be just sweet as.

    http://rollvic.org.au/events/aro/aro-2012/aro-2012-registration/

    Posted 7 years ago on Monday December 3, 2012 | Permalink
  2. I tried submitting your form and it first hung waiting for Facebook, then it hung trying to load some resources from 192.168.1.3, which is never going to work. Then it was trying to load more from Facebook static.ak.fbcdn.net. Then back to 192.168.3.1.

    Please resolve those errors before we take another look.

    If you want to land somewhere other than the existing page after form submission, you should select "Page" or "Redirect" rather than "Text" from the confirmation tab on the form settings. A Text confirmation will reload the same page, with no form, and show your confirmation text. Maybe that's what you're seeing?

    Posted 7 years ago on Monday December 3, 2012 | Permalink
  3. Sweet, cheers for checking, mustn't have moved properly when migrating from local machine. Will resolve the first issues you mentioned then see if that does the job.

    Posted 7 years ago on Monday December 3, 2012 | Permalink
  4. Hmm ok I checked the database and the only entries for 192.168.1.3 and Facebook were within the widget content so I've removed all widgets, disabled all plugin except for GF and have reverted back to the twenty ten theme without any customisation and I'm still having the issue.

    On looking at the console during submit it says 404, but other than that I'm not sure how to troubleshoot further. If you have any other suggestions that would be great. Will check back in a few hours

    Posted 7 years ago on Monday December 3, 2012 | Permalink
  5. What does your confirmation text look like? I see some different problems now, but I'm not sure where they're coming from.

    Posted 7 years ago on Monday December 3, 2012 | Permalink
  6. Actually, if you just load this page, it shows in the browser but the status header is still a 404.

    http://rollvic.org.au/events/aro/aro-2012/aro-2012-registration/

    Can you try with default permalinks and see if the result is the same?

    Posted 7 years ago on Monday December 3, 2012 | Permalink
  7. The confirmation text shouldn't be an issue as I've also noticed the contact form was having the exact same problem and it has the default confirmation message.

    I've turned off permalinks now and it works for both forms
    Contact form: http://rollvic.org.au/?page_id=33
    Registration form (original one posted with issues): http://rollvic.org.au/?page_id=120

    Anything I can try next to get permalinks back on?

    Posted 7 years ago on Monday December 3, 2012 | Permalink
  8. Have you tried activating them again? Maybe the rules just needed to be flushed.

    Posted 7 years ago on Tuesday December 4, 2012 | Permalink
  9. Still same issue now that I've put permalinks back on i'm afraid

    Posted 7 years ago on Tuesday December 4, 2012 | Permalink
  10. Hey Chris, any chance I can have some more help with this? I have applied the latest gf forms update and am running WP3.5 RC3 now and still the same issue. Please let me know what else I can try. I am going to have to remove all my gravity forms shortly on this website and use something else as I need to have the forms working.

    Posted 7 years ago on Tuesday December 4, 2012 | Permalink
  11. ok I've got it working!
    I created a test page to add forms to so we could still work on this while I used another form plugin on the live pages and when I added the forms to the new pages, they work totally fine now.

    Perhaps you were right in the permalinks needed to be flushed but this will be a good new troubleshooting step if I'm ever having issues - create a new page and add the form to see if same issues exist.

    Thanks

    Posted 7 years ago on Tuesday December 4, 2012 | Permalink
  12. Please let us know if you run into any more trouble.

    Posted 7 years ago on Thursday December 6, 2012 | Permalink

This topic has been resolved and has been closed to new replies.