PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Ajax submit won't work

  1. Nick
    Member

    Link in question: http://fivereasonstodive.com/share-your-top-five-reasons-to-dive/facebook-submit/testing/fan-page/

    WP 3.2.1
    GF 1.5.2.8
    Genesis 1.7.1

    Tried disabling all other plugins, tried default theme, tried both all plugins disabled AND default theme

    Using the insert form button, all I have in the editor is this:
    [gravityform id=4 name=Testform ajax=true]

    The form submits fine, but not using ajax.

    What am I doing wrong?

    Posted 8 years ago on Thursday September 22, 2011 | Permalink
  2. I don't see that this form has ajax enabled. Can you re-enable the ajax so we can test with it on please?

    Posted 8 years ago on Thursday September 22, 2011 | Permalink
  3. Nick
    Member

    It's enabled via the shortcode. If that doesn't enable it, I'm not sure what else to do since I checked the box and it says "ajax=true" in the shortcode.

    Posted 8 years ago on Friday September 23, 2011 | Permalink
  4. Is it currently embedded with the ajax enabled? The form that is rendered in that page is not set up to submit via AJAX. Just a normal form submission.

    There are a lot of jQuery and AJAX things going on on that page, so it might be a plugin or script conflict.

    Can you submit the form from the preview with AJAX enabled?

    Posted 8 years ago on Saturday September 24, 2011 | Permalink
  5. Firebug is showing that the "admin-ajax.php" file is trying to be loaded on the front end when it shouldn't be.

    screenshot: http://bit.ly/obi43D

    I'm not sure that's the origin of your problem, but it seems suspicious. You may want to go ahead and test for a theme/plugin conflict to see if you can narrow it down.

    Posted 8 years ago on Saturday September 24, 2011 | Permalink
  6. What's also weird is the multiple domain names there:

    http://aquaviews.net/fivereasonstodive.com/wp-admin/admin-ajax.php
    http://aquaviews.net/
    fivereasonstodive.com

    Posted 8 years ago on Saturday September 24, 2011 | Permalink
  7. Nick
    Member

    The form is embedded with the same embed code as above. I've put it back to the default theme, turned off every plugin except GF and have fixed the multiple domain "issue". Firebug doesn't show any problems. Still doesn't work.

    Posted 8 years ago on Wednesday September 28, 2011 | Permalink
  8. Nick, any idea why the domain names are doubled up like that? Is this actually a directory on your server:

    [php]
    ~/fivereasonstodive.com/wp-admin/
    Posted 8 years ago on Wednesday September 28, 2011 | Permalink
  9. Nick
    Member

    Yes, that is a directory on the server. They shouldn't be doubled up in terms of paths anymore. It was part of the development process. The original site (aquaviews) was on a basic hosting plan and the client was being cheap during development by not wanting to upgrade to a hosting plan that allowed for more than one domain on the account.

    Posted 8 years ago on Thursday September 29, 2011 | Permalink
  10. Nick
    Member

    So any suggestions on this one? I'd really like to get this feature working.

    Posted 8 years ago on Monday October 3, 2011 | Permalink
  11. The issue is the reCAPTCHA field. A limitation of the reCAPTCHA service is it not compatible with AJAX. So Gravity Forms automatically disables AJAX if a reCAPTCHA field is present to prevent problems from occurring with reCAPTCHA.

    If you want to use AJAX and use a Captcha you can install the Really Simple Captcha plugin. Once you activate that plugin it will add additional options to the Captcha field in Gravity Forms.

    Posted 8 years ago on Monday October 3, 2011 | Permalink
  12. Nick
    Member

    Thanks, that did the trick!

    Posted 8 years ago on Tuesday October 4, 2011 | Permalink

This topic has been resolved and has been closed to new replies.