PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

All Submitted Fields

  1. Somewhere in the updates the All Submitted Fields option took on a different form, and it's not really working for me.

    I appreciate how it's cleaned up the email, but for my purpose, it's imperative that all hidden fields be displayed on the admin email. Departments all over campus use it for the "Departmental Use Only" area. Most of them print the email, pass it for required approvals and file it in a physical student file. The hidden fields serve as checkboxes and signature fields.

    Is there some option I'm not aware of? I have a form result from Nov. 12 that's perfect, and one from yesterday that's not so much.

    Posted 10 years ago on Tuesday November 24, 2009 | Permalink
  2. Shelley, for clarification so I am on the same page... the issue is that hidden fields are not being displayed when using the all_fields variable correct?

    Posted 10 years ago on Tuesday November 24, 2009 | Permalink
  3. Or is the issue that the all_fields isn't outputting blank fields... if a field has a value it displays it, if the field doesn't have a value it does not display it... is that the change you have an issue with?

    Posted 10 years ago on Tuesday November 24, 2009 | Permalink
  4. I think it might be a combo of both (or a symptom of the same change). The hidden fields won't be filled in when the user initially submits the form, so if you've coded it not to display empty fields, they're left out.

    I can see the point in leaving off empty fields, especially when the all_fields email is formatted so large. Can you restructure the logic to leave out non-hidden empty fields?

    Posted 10 years ago on Tuesday November 24, 2009 | Permalink
  5. Right now I do believe that it only leaves out blank fields, hidden or not. We are going to add a parameter for the all_fields variable that will allow you to tell it to show all fields, even if the field value is blank. This should solve this problem. This update will be in the upcoming v1.3.5 release.

    Posted 10 years ago on Tuesday November 24, 2009 | Permalink
  6. That outta do it. Is there an eta on that release? I need to figure out if I can hold off the torch & pitchfork toting villagers or if I need to implement my own fix.

    Posted 10 years ago on Tuesday November 24, 2009 | Permalink
  7. It will probably be released on Friday. Monday at the latest.

    Posted 10 years ago on Tuesday November 24, 2009 | Permalink
  8. Hey Shelley, 1.3.5 has been released and it includes a new variable you will want to use to show all fields (including fields with no values).

    The new form field variable is:

    {all_fields_display_empty}

    This will return all submitted fields, including hidden and empty fields.

    Posted 10 years ago on Monday November 30, 2009 | Permalink
  9. Awesome, but it doesn't appear to be available in the dropdown. Am I missing something or did it get overlooked?

    Posted 10 years ago on Monday November 30, 2009 | Permalink
  10. It's not in the drop down Shelley, right now it's an option for advanced users that will appear in the documentation but not in the drop downs itself. You will have to manually add that variable where you want it to display in the Notifications.

    Posted 10 years ago on Monday November 30, 2009 | Permalink
  11. Alrighty, that'll work.

    Posted 10 years ago on Tuesday December 1, 2009 | Permalink
  12. This worked perfectly, but would be nice if it were a setting the client could select.

    Posted 7 years ago on Monday November 12, 2012 | Permalink

This topic has been resolved and has been closed to new replies.