PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

{all_fields} don't display in email

  1. KhakiMan
    Member

    One of my longer forms, which has a number of required fields, is not passing field entries to the email, which simply uses the {all_fields} tag.

    The form contains 9 required fields, but the email is only providing 3 fields.

    The form has not been changed since the site launched 2 months ago.
    The only change has been upgrading Gravity Forms to most recent releases.

    Posted 9 years ago on Wednesday March 24, 2010 | Permalink
  2. We would need a WordPress admin login to this site in order to check your form settings and run some tests. You can send us this information via our Contact Us form and reference this forum post.

    Posted 9 years ago on Wednesday March 24, 2010 | Permalink
  3. The problem is most likely related to the fact you have database caching implemented on your site via the W3 Total Cache plugin.

    Because this is turned on, Gravity Forms is not getting accurate data back from the database because W3 Total Cache is caching that information and returning cache instead of actual data.

    Database caching also causes problems with form submissions, depending on how often the cache is refreshed.

    You will need to disable the Database Caching feature of W3 Total Cache. It is a setting on the W3 Total Cache Settings page.

    This isn't a conflict or a bug, W3 Total Cache is doing what it is supposed to do with Database Caching turned on. However, this causes problems for plugins that need live data and not cached data in order to work properly. W3 Total Cache will be "whitelisting" the Gravity Forms related database tables in a future release, however I am not sure when that will happen as that is up to their developer.

    This isn't going to correct any existing data but should clear things up going forward.

    Posted 9 years ago on Thursday March 25, 2010 | Permalink
  4. KhakiMan
    Member

    Thanks for your quick response in identifying the issue! Fantastic support!!

    Posted 9 years ago on Friday March 26, 2010 | Permalink

This topic has been resolved and has been closed to new replies.