PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Another Fatal Error Activating Plugin

  1. I am trying to install the gravity form on http://www.redchip.com.au and When I go to activate it I get the following error:

    Fatal error: Class 'WP_Widget' not found in /usr/home/redchip/html/wp-content/plugins/gravityforms/widget.php on line 12

    Which I have not seen anywhere else. The host is running php 5.

    Any ideas why this might be happening?

    ed

    Posted 11 years ago on Friday December 10, 2010 | Permalink
  2. Your WordPress version (2.7.1) is old and does not support widgets, which is why the widget class is not found. You need to upgrade WordPress and then this error will disappear.

    Posted 11 years ago on Friday December 10, 2010 | Permalink
  3. Yes, as illinoisharley said it appears you are running an old version of WordPress that does not support Widgets as the WP_Widget class is a core class. You need to upgrade the version of WordPress you are running and you should ALWAYS run the latest version of WordPress for security reasons if nothing else.

    Posted 11 years ago on Friday December 10, 2010 | Permalink