PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

? appended to confirmation page URL

  1. On submit, the form sends as it should. But on the confirmation page, a '?' gets appended to the URL. Often the result page doesn't show.

    It's an oddly inconsistent problem. The '?' seems to show up consistently.
    On my machine, the '?' shows up AND the page displays. But other users are reporting that the resultant page doesn't show.

    I've deactivated all the plugins and then put them back one at a time. I don't have a big list of plugins (just 7) They're up to date. I have about 30 different forms.

    Here's the link to a form: http://www.adhdcoaches.org/?p=2658

    Carl Hancock said.. in another answer...

    @kerchmcc I wasn't able to replicate this issue. The ? may be because you have enabled query string redirect options in your form confirmation. I submitted a form on that page and everything worked just fine.

    The form is really simple... just name, email and phone, no captcha
    no special form settings and no query strings.

    Thanks.
    kerch mcconlogue

    Posted 8 years ago on Friday August 12, 2011 | Permalink
  2. You said the form was simple.... but didn't say what you Confirmation settings are.

    When I tested your form it redirected to another page rather than showing me a thank you message. This tells me you have configured your form to redirect to another page, which may or may nto be necessary depending on what you are trying to accomplish. Typically forms just display the confirmation message.

    To view your Confirmation settings:

    - Edit your form
    - Go to Form Settings
    - Select the Confirmation tab

    I'm guessing it's configured to Redirect. Is the Pass Field Data Via Query String option also checked? See this screenshot: http://i.imgur.com/hn55E.png

    Posted 8 years ago on Friday August 12, 2011 | Permalink