PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Backend Javascript/Image/CSS issues after install?

  1. lizfulghum
    Member

    I've run an install of this plugin on two separate blogs on the same server (Latest released version of wordpress, PHP5). One worked perfect - the other, not so perfect.

    I'm have a variety of odd issues occurring that I'm not sure how to resolve; here's what's happening:

    - In firefox, it seems like most CSS styling and javascript is broken. Lots of missing images. The form admin is unusable. I'm chalking this up to some weird cache issue because...
    - IE fairs better and is usable, but I'm still getting jquery javascript errors (especially on popups help tool tips, and when I included a single quote in one of the fields I was editing). A few broken images - but they do actually exist on the server. They're just not loading (same as firefox).

    I've tried the following:

    -Deactivating and reactivating the plugin.
    -Deactivating the plugin, deleting, re-uploading via FTP.
    -Deactivating the plugin, deleting, re-uploading the zip via WP backend
    -Deactivating ALL other plugins on the site.

    I'm not sure what's up and my troubleshooting powers have failed me, any assistance?

    I'm sure it must be some sort of compatibility issue, but as I've already disabled every other plugin in existence, I'm not sure what could be doing it.

    Thanks in advance.

    Posted 11 years ago on Wednesday May 12, 2010 | Permalink
  2. It sounds like it is permissions related on the server, which is why images would be appearing as broken even though they exist on the server. This can happen when the permissions are set so that they won't load in the browser, they will act like they don't exist because the browser doesn't have permission to view them.

    Make sure ALL gravityforms plugin files are set to CHMOD 755 or CHMOD 777 and then test it and see if you encounter the same issue.

    Posted 11 years ago on Wednesday May 12, 2010 | Permalink
  3. lizfulghum
    Member

    Set to 777 just to cover all the bases -- with no change.

    Interestingly enough, right clicking and viewing the image returns "No input file specified." eg (http://www.popculturetees.com/wp-content/plugins/gravityforms/images/gravity-title-icon-32.png)

    Posted 11 years ago on Wednesday May 12, 2010 | Permalink
  4. I've never encountered this before. It's most certainly a server related issue. The fact that the image file exists on the server but if you try and access it directly via your browser and it returns that error is a big red flag that something else is going on.

    You may want to try searching Google for the "No input file specified" error message... I have never encountered that message before.

    Posted 11 years ago on Wednesday May 12, 2010 | Permalink
  5. lizfulghum
    Member

    In case anyone else runs into a similar problem:

    Solution for me = deleting the entire actual plugin folder (after backing up my existing plugins) and then reinstalling Gravityforms. Confirmed working, then re-added all the other plugins.

    Still no clue about why or how it got broken - but at least it's fixed.

    Posted 11 years ago on Wednesday May 12, 2010 | Permalink