PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Forms spontaneously stop being able to be saved

  1. scversilleescver
    Member

    Just reporting this issue for investigation in future upgrades. I spent the last three hours creating several different forms. 4 of them reached a point were the when the update button was pressed the page would just hang with the save wheel rotating indefinitely.Nothing special was done with the forms that ended up generating this error, they were simply long (15 to 25 fields).

    there was no way that I could salvage them once they generated this error, I simply had to delete them and start from scratch. Making a copy of them simply created another form with the same error.

    Posted 8 years ago on Sunday May 16, 2010 | Permalink
  2. Edited the title because this isn't a confirmed bug. It's most likely something unique to your installation. Thanks for the report, we'll keep an eye out for anything related.

    Posted 8 years ago on Sunday May 16, 2010 | Permalink
  3. Naomi
    Member

    I am having the same issue - latest version of GravityForms on WordPress 3.0 beta2

    Posted 8 years ago on Tuesday May 18, 2010 | Permalink
  4. I can't seem to replicate the issue on my side. I'm using WordPress 3.0-beta2-14697 and running/saving Gravity Forms 1.3.12 without any problems.

    My Installation Status

    Have you tried systematically deactivating plugins to see if there is a conflict there?

    Posted 8 years ago on Tuesday May 18, 2010 | Permalink
  5. Naomi
    Member

    I'm not running any other plugins (see here) - I noticed that the issue only occurred when I tried to add a checkbox or multiple choice field. When I added a section header instead, it saved.

    Here's my form:

    after adding a section header

    when trying to add a checkbox

    Posted 8 years ago on Tuesday May 18, 2010 | Permalink
  6. Naomi
    Member

    I just tried creating another form with a checkbox or multiple choice and it would not save so I'm pretty sure that's the issue. Once I deleted those fields, it immediately saved.

    Posted 8 years ago on Tuesday May 18, 2010 | Permalink
  7. We would need a login to your site in order to look at this. We can't replicate it on our end. It's working fine for us in WordPress 3.0 beta 2. You can send us a login via our Contact Us form and we can take a look.

    Posted 8 years ago on Tuesday May 18, 2010 | Permalink
  8. erikajurney
    Member

    Any resolution here? I just purchased gravityforms less than an hour ago and I'm having this problem too. WP 2.9.2.

    Posted 8 years ago on Friday June 25, 2010 | Permalink
  9. I'm personally not aware of the resolution was to the problem above, but there is an issue saving forms that occasionally creeps up. It's not a bug, it's something due to a specific security configuration on some hosts.

    You can see this post from a while back that gives some details.

    http://forum.gravityhelp.com/topic/unable-to-saveupdate-form#post-2758

    I'm not saying that this IS the issue, but it could be. Can you create and save a new form? Does your current form use a dropdown/select box?

    Posted 8 years ago on Friday June 25, 2010 | Permalink
  10. Kevin, I posted a comment on that other topic re: mod_security and SQL injection.

    Every once in a while I think hosts mess with mod_security because they're having a slow day or whatever. One day it's Bluehost, then Hostgator, then Godaddy. It would be nice if they communicated the changes, but they don't always.

    Posted 8 years ago on Saturday June 26, 2010 | Permalink
  11. erikajurney
    Member

    OK, pretty reliably this is how to recreate the problem on my end.

    Create a new form.

    Add a radio/checkbox field.

    Do *not* save your form.

    Add any other field.

    Save.

    It hangs and hangs...

    If I add a checkbox/radio field and save right away it is fine.

    Posted 8 years ago on Saturday July 3, 2010 | Permalink
  12. @erikaJurney Have you checked for plugin and theme conflicts by deactivating all other plugins and activating the default WordPress theme? That is the first thing you must do. Determine if one of your other plugins or themes is causing this issue.

    The second thing you must do is check to see if your web host is running mod_security. Mod_security is a firewall that depending on it's settings can prevent some AJAX from functioning properly.

    Posted 8 years ago on Monday July 5, 2010 | Permalink
  13. I was curious about this so I followed the instructions to recreate the issue here and recorded the screen.

    http://chrishajer.com/gravity/gf-save-hang.avi (2.86MB avi direct download)

    My installation:

    • WordPress 3.0
    • Twenty Ten theme
    • Gravity Forms 1.3.12.2
    • No other plugins active

    Here is my phpinfo();
    http://chrishajer.com/info.php

    I had no problem creating and saving a new form in either Chrome 6.0.453.1 dev or Firefox 3.6.6 on Windows XP SP3, using both radio buttons or checkboxes as my first field (no save), then adding another field (I added both paragraph fields and single line text) and then save.

    Just another data point to consider, but I was unable to recreate the issue in my test installation.

    Posted 8 years ago on Tuesday July 6, 2010 | Permalink
  14. erikajurney
    Member

    Here's what finally solved this problem for me:

    http://forum.gravityhelp.com/topic/cannot-edit-any-forms-stalls-at-saving-form-please-wait#post-9534

    Posted 7 years ago on Monday January 31, 2011 | Permalink