PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Bug found in Dynamically creating conditional logic & required fields

  1. I have created a field that shows or hides based on conditional logic that I generate myself using the $field['conditionalLogic'] item, the conditional logic works fine to show or hide fields.

    I think there are two bugs in the system.

    1. When the field I have set dynamic conditionalLogic on is set to be required within the UI this doesn't present the same logic as when you setup conditional logic within the form. So when that field is hidden the requirement for a value isn't needed, this is what I could expect when I setup my own $field['conditionalLogic'] item.

    2. On discovering the first issue I decided to override the field validation myself using gform_field_validation_x_y and checking to see if that field was hidden or not. However I believe there is an issue with checking that field is hidden when processing a gform_field_validation . I have used gform_field_validation_x_y before to process custom validation on required fields.
    However when I use RGFormsModel::is_field_hidden to check if the field if hidden with in the custom function it is always returning false(bool).

    function fieldValidationCheckHiddenFixed($result, $value, $form, $field){
    $is_hidden = RGFormsModel::is_field_hidden($form, $field, array());
    var_dump($is_hidden);
    }

    Can you let me know if these two items are bugs within GravityForms or am I doing something incorrectly?

    Regards

    Posted 8 years ago on Thursday January 12, 2012 | Permalink
  2. Bump, I am having this same issue.

    Posted 8 years ago on Saturday January 21, 2012 | Permalink