PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Can't save form when using Post Fields

  1. Hi, I'm trying to create a form that uses a Post Field (Title, Body, Image, etc.) however when I try to save it, I get the "There was an error while saving your form. Please contact our support team." message.

    Here's what I've tried so far in various combinations:
    -Deleting and recreating the form
    -Deactivating all of the plugins
    -Uninstalling and reinstalling Gravity Forms using the Settings > Uninstall option then building a form again from scratch
    -Checked the DB_CHARSET and DB_COLLATE defintions

    I don't that that it is a server resource issue because I have another WordPress install on the same server using the same theme and I can save a form with a Post Field without error.

    Can anyone make any suggestions on how to get around this error? I'd be happy to provide any additional information.

    Thanks for your help.

    Posted 7 years ago on Tuesday October 9, 2012 | Permalink
  2. First, how much RAM is available to PHP and WordPress?

    Secondly, please check for theme and plugin conflicts http://rkt.gs/testing - sounds like the theme should not be the issue since you have another site which is fine. But please check for both theme and plugin conflicts to be sure.

    Can you create this exact for in your other WordPress installation on the same server, with the same theme? I would ask you to export the theme and try installing it on the good installation, but since it does not save on the bad installation, that would not help. So, can you create exactly the same form on the server where the form with post fields work? Maybe it is one specifically titled field or one type of field.

    Please report what you find. Thank you.

    Posted 7 years ago on Wednesday October 10, 2012 | Permalink
  3. I've done some debugging to try to figure out what's going on. It looks like save_form_info call on line 2611 in form_detail.php is returning invalid_json. I put in some code to give me the json that it's trying to use and ran it through a json validator. In every instance this value pair

    "postAuthor": undefined

    is always flagged as the invalid culprit. I've tried changing the Default Post Author in the Post Fields but I'm still getting the same error. Any suggestions about what to do?

    Thanks!

    Posted 7 years ago on Tuesday October 16, 2012 | Permalink
  4. Also, I forgot to mention, I did run through the recommendations in the link that you provided and it seems to work out fine.

    Posted 7 years ago on Tuesday October 16, 2012 | Permalink
  5. That's good debug information: thank you. I have flagged this for the developers to take a look at.

    Posted 7 years ago on Wednesday October 17, 2012 | Permalink
  6. We were not able to replicate this problem, but I have a new version of the plugin which made a change which may help you with this. Please send me an email at chris@rocketgenius.com so that I can email you the new version. Please include a link to this topic so I know what we're talking about. Thank you.

    Posted 7 years ago on Wednesday October 17, 2012 | Permalink
  7. I emailed you the new version. Please update the topic if this helps you. Thanks.

    Posted 7 years ago on Friday October 19, 2012 | Permalink
  8. Argh. I'm having this problem also. Have spent a good few hours on this now. I have a new developer license and it worked for the first few hours, now I'm receiving this error.

    Can I please have the new version also? I can give admin login info if you want to replicate on my account.

    Richard

    Posted 7 years ago on Sunday October 21, 2012 | Permalink
  9. Richard, please send an email to chris@rocketgenius.com and include a link to this topic so I know what you're talking about when you email me. Thank you.

    The new version fixed the problem for @BlueZoo.

    Posted 6 years ago on Tuesday October 23, 2012 | Permalink
  10. Richard, I received your email and sent the latest version.

    Posted 6 years ago on Wednesday October 24, 2012 | Permalink
  11. I am getting the same thing. I have been on the support forum for hours done everything, deactivated the plugins, wordpress default theme, etc. I have been on the phone with hosting company trying to fix anything that may cause it, but nothing.

    It was working couple days ago, but all of a sudden, I can not re-save a form without getting this message.

    Anything else I can try?

    Posted 6 years ago on Friday February 8, 2013 | Permalink
  12. @rosspub, I will close this topic as I see you have opened a new one already:
    http://www.gravityhelp.com/forums/topic/error-while-saving-your-form-1#post-144716

    Posted 6 years ago on Saturday February 9, 2013 | Permalink

This topic has been resolved and has been closed to new replies.