PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Can't see Gravity Forms tab in Dashboard after activation

  1. Hello,

    I have uploaded and activated my recently purchased business license Gravity Forms pliugin, however I cannot see any trace of any options to aaccess it. It shows up under my plugins page as activated and yet there's no sign of it. When I go to 'edit' the plugin, all the files show up and I've even manually inserted my license key into .php file. Yet still nothing show's up. Supposedly I'm suppose to see a 'Forms' tab on the left sidebar, but I don't.

    Also, I've switched to the default theme and yet nothing changes. I've also deactivate my plugins but nothing still shows up.

    Please could someone out there be ever so kind as to help me out. It would be much appreciated.

    Posted 10 years ago on Wednesday August 31, 2011 | Permalink
  2. Sounds like you have something like the Members plugin by Justin Tadlock? If so, you will need to give your role all the Gravity Forms permissions.

    Do you have the Members plugin or other role manager plugin installed?

    Also, don't edit any of the plugin files. The plugin will still work without the license key, so you can take that out of there. The real solution is to have the Forms menu show up. What happens if you try to load this URL for your site?

    http://example.com/wp-admin/admin.php?page=gf_edit_forms

    If it's not role management, there are a couple other things it can be.

    Posted 10 years ago on Wednesday August 31, 2011 | Permalink
  3. Hi Chris,

    Thanks for the quick reply... I've tried disabling my role plugin ( and all other) and yet still nothing shows up. When I load that url you recommended; it brings up a basic site with the following text "Example Domains
    As described in RFC 2606, we maintain a number of domains such as EXAMPLE.COM and EXAMPLE.ORG for documentation purposes. These domains may be used as illustrative examples in documents without prior coordination with us. They are not available for registration."

    What are these 'couple of other things' you speak of ? Thanks for your help...

    Posted 10 years ago on Wednesday August 31, 2011 | Permalink
  4. Replace example.com with your own website URL. Then try the same link.

    You were able to install and activate the plugin with no errors? It's possible not all the files were transferred, but that's a long shot. Deleting the plugin and reuploading and reinstalling may help if that's the case.

    What role manager plugin were you using? You don't necessarily have to disable it, but maybe just need to configure it to give yourself the gravivityforms_ permissions.

    The other things could be anything that has been added to the admin section with a fixed menu position (rare). Any other plugin could also foul it up.

    You can start at square one by testing for themes and plugin conflicts.
    http://www.gravityhelp.com/documentation/page/Testing_for_a_Theme/Plugin_Conflict

    Posted 10 years ago on Wednesday August 31, 2011 | Permalink
  5. Hello again,

    So after visiting the recommended link with my url, it says I don't have permission. I've deactivated my other role capabilities plugins but still nothing. I installed the 'members' plugin and still nothing happened. I deactivated it, and all other plugins and still no luck. Also changed to twenty ten theme and nothing happened

    Could it be that my wordpress 'registry' has coded my permission role and not changed it back after disabling plugins? Or something along the lines of my permission being written into the wordpress database and now perhaps I have to manually change it? If so, where do I start?

    Thanks again for your help; it's very much appreciated.

    Sincerely,
    Dewald

    Posted 10 years ago on Thursday September 1, 2011 | Permalink
  6. The capabilities are certainly stored in the database.

    Nothing really "happens" when you install the Members plugin. After installing it, you need to configure it. The first step is to navigate to Settings > Members (this URL for your site wp-admin/options-general.php?page=members-settings ).

    After that, you navigate to Users > Roles and then (assuming you are an administrator) you need to edit the administrator role to give it the Gravity Forms permissions. This is the URL. Add your website to the beginning wp-admin/users.php?page=roles

    The key here is to configure the plugin properly. It sounds like it's a permissions issue based on the fact that you did have a role management plugin (or plugins?) installed. Please try the Members plugin and configure it before deactivating it. Activate it, and continue until you have access to the Forms menu.

    Posted 10 years ago on Thursday September 1, 2011 | Permalink
  7. Hey Chris,

    So I tried accessing the above 'roles' url, but it says 'You do not have sufficient permissions to access this page.'.. Any idea? I've tried configuring the 'members' plugin, but the options are very limited...

    Thanks again. Hopefully this will be sorted out soon...

    Posted 10 years ago on Thursday September 1, 2011 | Permalink
  8. Somehow it sounds like your administrator role has lost capabilities. Do you have another administrator login, or just the one? Is this a multi-site installation? Does everything other than Gravity Forms work correctly? Has any portion of your admin been restricted by another plugin? I've seen some sites where admin access is restricted by a developer before he hands it over to a client, to prevent them from 'breaking' things.

    If you're comfortable with it, can you take a screenshot of your admin and email it to me at chris@rocketgenius.com so I can see if it looks "normal"? Something weird is going on, but I'm unsure if it's related to Gravity Forms. The fact that you cannot access the Roles section of your site has nothing to do with Gravity Forms.

    Posted 10 years ago on Thursday September 1, 2011 | Permalink
  9. Hey Chris,

    Wahoo!!!! After much switching of roles and capabilities; it seems I finally got it figured out. Seems like one of my 'admins' had more capabilities than the 'super admins', which had less than the 'superadministrators' and 'administrators'... so now I have a bunch of different roles all over the place, but luckily at least my 'Forms' option works. So I'll change/delete some roles later seeing as I've (you've) figured out the problem, or at least the root of it.

    Thanks again for the quick responses and useful information. Hopefully I won't need any more any time soon. :)

    Take care and much appreciated.

    Dewald Brand
    http://www.OneDogChicken.com

    Posted 10 years ago on Thursday September 1, 2011 | Permalink
  10. Glad you got that sorted out. Enjoy!

    Posted 10 years ago on Thursday September 1, 2011 | Permalink

This topic has been resolved and has been closed to new replies.