PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Captcha, Really Simple Captcha and Ajax

  1. I have the plugin [Really Simple Captcha] installed.
    When I use the Captcha field of the Gravity Form to add Captcha to the form it works fine and can be accessed by users without a problem.
    When I then try to edit the Captcha field, on the Gravity Form editor, to set a [Math Challenge] option from the [Really Simple Captcha] plugin, I get the message:
    {Ajax error while changing input type}.
    Do I have to turn-off Ajax? How can I do that on the Gravity Form editor?
    Thank you for your assistance.

    Posted 6 years ago on Saturday March 30, 2013 | Permalink
  2. That does not normally happen. I can switch between all three CAPTCHA types in my installation. Please check for theme and plugin conflicts to see if there is an error there. You can use these instructions http://rkt.gs/testing

    If that does not turn up any useful information, please enable WP_DEBUG temporarily to see if any errors are being logged. http://codex.wordpress.org/WP_DEBUG

    Posted 6 years ago on Monday April 1, 2013 | Permalink
  3. Hello Chris,

    Thank you for the info.

    Issue resolved.
    Your advice to enable WP_DEBUG temporarily, to see if any errors are being logged, was very valuable as this revealed that the [GD and FreeType PHP libraries] which are required by the plugin [Really-Simple-Captcha] were not installed on the server.
    The libraries were then installed and we can now switch between all three CAPTCHA types successfully.

    Many Thanks for your Prompt and Positive support.

    Regards. Andreas

    Posted 6 years ago on Monday April 1, 2013 | Permalink
  4. Thanks for the update. Glad that worked out for you.

    Posted 6 years ago on Monday April 1, 2013 | Permalink

This topic has been resolved and has been closed to new replies.