PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Change default admin email

  1. (posted this yesterday with no response, so I'm reposting)

    Currently, when I create a new form, it defaults notifications to the "Admin email" address. I need to switch that default to another user. They are currently an admin on the WP site, but how do I make that change as it pertains to Gravity Forms? Thank you!

    Posted 9 years ago on Thursday December 13, 2012 | Permalink
  2. You can enter their email address directly, rather than the merge tag {admin_email}. Does that work for you?

    Posted 9 years ago on Thursday December 13, 2012 | Permalink
  3. Ideally, no. I am changing positions and another person is taking over responsibility of the gravity forms. I would like him to be able to create forms without needing to remember to change the notification email address each time, so that we don't risk leads not being responded to in a timely manner. Any other possible solutions?

    Thank you for your response.

    Posted 9 years ago on Thursday December 13, 2012 | Permalink
  4. So you would like to change the default for all new forms from {admin_email} to something, so that it is accurate every time a new form is created, without having to worry about someone editing the notification?

    Posted 9 years ago on Thursday December 13, 2012 | Permalink
  5. Yes, exactly. Currently {admin_email} = my email address and I want it to be someone else's. I couldn't find where I could make that change (if it's even possible). Thanks!

    Posted 9 years ago on Thursday December 13, 2012 | Permalink
  6. I believe you can use the gform_notification_email
    http://www.gravityhelp.com/documentation/page/Gform_notification_email to override the default {admin_email}. You would make that one change in functions.php of your current theme and then all your forms would send the admin notification to this new email address.

    Posted 9 years ago on Thursday December 13, 2012 | Permalink
  7. Thank you for the workaround. I think that will work for what I need. Thanks!

    Posted 9 years ago on Thursday December 13, 2012 | Permalink
  8. At least it's only one place to edit and will work on all forms. I hope that works for you.

    Posted 9 years ago on Thursday December 13, 2012 | Permalink
  9. I attempted to use the code from that page

    <?php
    add_filter("gform_notification_email", "change_notification_email", 10, 2);
    function change_notification_email($email, $entry){
       return "ellis@iamsinc.com";
    }
    ?>

    and added it to the bottom of my functions.php file. It killed the whole blog with a syntax error (unexpected "<")

    Also, will that change override when I have specified an individual to receive a form notification? Thank you

    Posted 9 years ago on Wednesday December 19, 2012 | Permalink
  10. A syntax error means you pasted in something incorrectly. Please try removing line 1 (the opening <?php ) and see if the syntax error goes away.

    This will override the email address on all admin notifications. If you don't want that, you will need some different code to take a manually entered address into account.

    Posted 9 years ago on Wednesday December 19, 2012 | Permalink
  11. Just wanted to add the solution to this problem in case anyone else had it. Warning: the solution is painfully simple once you realize what it is. It's a Wordpress change. On the Admin Panel, go to Settings > General and change the admin email.

    Posted 9 years ago on Tuesday February 5, 2013 | Permalink
  12. That's a simple thing which is easy to overlook. Thanks for posting this.

    Posted 9 years ago on Wednesday February 6, 2013 | Permalink

This topic has been resolved and has been closed to new replies.