PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Checkboxes Not Showing Up

  1. ehong33234
    Member

    Running WooCommerce with GF Product Add-ons and latest GF.

    I have the Pricing Field OPTION set to checkbox and I see the heading and the price calculates correctly, however, the actual checkbox is not showing up.

    I noticed the same thing for your DEMO. http://lucasstark.com/estore/shop/simple-product-a/

    Notice the checkbox option but you can't see the actual box.

    Posted 6 years ago on Wednesday November 7, 2012 | Permalink
  2. ehong33234
    Member

    I am running WooCommerce Mystile theme and preview of the form shows the standard Mac OS checkboxes fine. Tried on Safari and Chrome.

    Posted 6 years ago on Wednesday November 7, 2012 | Permalink
  3. ehong33234
    Member

    You can see the issue here: http://goo.gl/4lMRm

    Toward the bottom where it says "rush delivery" there should be a checkbox showing.

    Posted 6 years ago on Wednesday November 7, 2012 | Permalink
  4. It looks like a the absolute positioning (line 2787 of your theme's style.css file) is causing the issue. It appears your theme is doing something and replacing the default checkbox inputs with other characters. If I disable that property, then the input shows up fine..

    Chrome screenshot: http://bit.ly/XkRSKG

    Oddly enough, it works fine in Firefox.

    Firefox screenshot: http://bit.ly/U9Sooj

    You will want to talk to your theme developers if you need additional guidance on the theme styling and whatever they're doing to replace the inputs.

    Just to be clear.. the demo you referenced above is a WooTheme's demo, not Gravity Forms. It's to feature their theme/e-commerce functionality.

    Posted 6 years ago on Wednesday November 7, 2012 | Permalink
  5. ehong33234
    Member

    Hey Kevin, thanks for taking a look and clarifying. I'll take it up with WOO.

    Posted 6 years ago on Wednesday November 7, 2012 | Permalink
  6. Sure thing. Good luck with it. I'm sure they'll be able to help you out.

    Posted 6 years ago on Thursday November 8, 2012 | Permalink
  7. ehong33234
    Member

    Just wanted to follow up with a solution that I found - hope it helps someone else in the future. I emailed WooThemes about 12 hours ago and haven't heard a response back yet but after poking around, I was able to add some custom CSS in the Dashboard > Appearance > Editor > Custom.css

    Basically, the MyStile theme is hiding the standard browser checkbox and radio button and opting for the themes version, however, it wasn't working. So I went to the CSS and looked up checkboxes (and radio since radios were quirky too) and sure enough, it says this:

    /* Hides the default checkbox style */

    The code right above that phrase is: -webkit-appearance: none;

    I changed it to: -webkit-appearance: checkbox;

    (same for radio) and now it works perfectly fine on all browsers.

    Posted 6 years ago on Thursday November 8, 2012 | Permalink
  8. Thank you for the update.

    Posted 6 years ago on Thursday November 8, 2012 | Permalink

This topic has been resolved and has been closed to new replies.