PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Code Update to Fix post_submission

  1. gcampbell

    Just FYI. The gform_post_submission was not firing. After checking the source code in form_display, I moved the two "do_actions" to "before" the redirect statement. It now looks like the following

    do_action("gform_post_submission", $lead, $form);
    do_action("gform_post_submission_{$form["id"]}", $lead, $form);
    header("Location: {$confirmation["redirect"]}");

    This fixed the issue I was having and the event NOW fires :)

    Posted 12 years ago on Wednesday July 13, 2011 | Permalink
  2. mneisser

    I have a custom external form submission that uses gform_post_submission that worked fine for a year and then just stopped working a couple weeks's been driving me crazy. Is this a known error in new version that gform_post_submission doesnt work?

    Posted 12 years ago on Monday July 25, 2011 | Permalink
  3. mneisser

    gcampbell: i tried you fix, but still not working for me. How do I test if its firing correctly?

    Posted 12 years ago on Monday July 25, 2011 | Permalink
  4. mneisser - can you the code that's not working for you (also: what it used to do and what it does now)? If the code you post is long, please use a service like Pastie or PasteBin to host your code and paste the link here. Thanks.

    Posted 12 years ago on Monday July 25, 2011 | Permalink
  5. mneisser

    It posts the form to an external crm. It used to post my gravity forms data to the weblead function on the external CRM. Now, gravity forms submits fine, but not receiving the lead ath the CRM. I tested a manual form submission on the crm web lead and that site is functioning correctly. Here is the code.

    Posted 12 years ago on Monday July 25, 2011 | Permalink
  6. @mneisser,
    There are no known issues with the gform_post_submission hook not firing. I can't replicate your problem locally, so I will need to take a closer look at your environment. I will need a WP admin and FTP login. If you can send them to, I will be glad to see what is going on and try to get it resolved for you. Please also include a link to this thread.

    Posted 12 years ago on Monday July 25, 2011 | Permalink
  7. mneisser

    just sent you info. thanks for the response and help.

    Posted 12 years ago on Tuesday July 26, 2011 | Permalink
  8. I am having the same problem as mniesser, tried the little hack of moving the lines around in form_display but still does not work for me.

    Trying to do a similar thing; post to an external crm.

    Is there any news of a bug here or a solution?

    Posted 12 years ago on Monday August 15, 2011 | Permalink