PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Combining Gravity Forms With Buddypress

  1. Mayfly
    Member

    I'm trying to add a form in the sidebar of a specific Buddypress page (in this case, the 'Activity' page) like so:

    <?php echo do_shortcode('[gravityform id=1 title=false description=false ajax=true]'); ?>

    However the form does not submit properly, I see the spinning icon to show that *something* is being processed. However after that, nothing happens.

    I get no confirmation message and receive no validation messages if I input anything incorrectly.

    I've tried another form in the same place and that doesn't work either. However, if I view a standard page on the website (e.g. a page that I've created myself, such as 'About Us') then the form works fine there.

    I've also upgraded both plugins to the latest version but with no joy.

    Has anyone else had this issue or does anyone know a way around it?

    Posted 7 years ago on Tuesday July 10, 2012 | Permalink
  2. Mayfly
    Member

    Thanks however the problem still persists even after pasting this code into functions.php.

    It's a little different in fact, in the sense that the spinning wheel icon never stops, whereas before it used to spin for several seconds before just disappearing.

    Posted 7 years ago on Wednesday July 11, 2012 | Permalink
  3. Since you used the function call to embed your form, did you also enqueue your styles and scripts?
    http://www.gravityhelp.com/documentation/page/Embedding_A_Form#Function_Call

    See the section at the bottom:
    http://www.gravityhelp.com/documentation/page/Gravity_form_enqueue_scripts

    Posted 7 years ago on Wednesday July 11, 2012 | Permalink
  4. Mayfly
    Member

    Thanks, I've updated header.php like so:

    <?php
    	if ( is_singular() && bp_is_blog_page() && get_option( 'thread_comments' ) )
    		wp_enqueue_script( 'comment-reply' );
    
    	gravity_form_enqueue_scripts(1, true);
    
    	wp_head();
    ?>

    As well as added this at the bottom of functions.php:

    // remove existing action and rebind at a higher priority
    remove_action('wp',  array('RGForms', 'maybe_process_form'));
    add_action('wp',  array('RGForms', 'maybe_process_form'), 3);

    However the problem still persists. The loading icon now goes back to loading for a few seconds before disappearing (oddly enough, there are sometimes two loading icons next to each other instead of just the one)

    Posted 7 years ago on Thursday July 12, 2012 | Permalink
  5. Can you share a link to your form please? (The page with the form embedded) Thanks

    Posted 7 years ago on Thursday July 12, 2012 | Permalink
  6. Mayfly
    Member

    The page is password protected but I could set you up with a user account so you can view it if you like?

    Thanks

    Posted 7 years ago on Monday July 16, 2012 | Permalink
  7. Sure, you can send that information to chris@rocketgenius.com when you have it. Thanks

    Posted 7 years ago on Monday July 16, 2012 | Permalink
  8. Mayfly
    Member

    Thanks! I've added you now, you should have an email with your password.

    Posted 7 years ago on Tuesday July 17, 2012 | Permalink
  9. @Mayfly, I don't have an email from you. Can you send me an email to chris@rocketgenius.com please and let me know what domain the email should have come from so I can check my spam folder or other places?

    Posted 7 years ago on Tuesday July 17, 2012 | Permalink
  10. Mayfly
    Member

    Hello,
    Just wondering if you received my email yesterday informing of the domain name?

    Posted 7 years ago on Thursday July 19, 2012 | Permalink
  11. Mayfly
    Member

    Hi Chris, did you get the email?

    Thanks.

    Posted 7 years ago on Tuesday July 24, 2012 | Permalink
  12. I did not. Please send the email again to chris@rocketgenius.com and be sure to reference this post. Thanks.

    Posted 7 years ago on Tuesday July 24, 2012 | Permalink
  13. Mayfly
    Member

    Hi Chris,
    I've forwarded the original email just now, subject is 'Fwd: Mayfly Gravity Forms Help'.

    Thanks.

    Posted 7 years ago on Thursday August 2, 2012 | Permalink
  14. @Mayfly, I have not received anything yet, which is strange. I just sent you an email. Please respond to that with the information. Thanks.

    Posted 7 years ago on Friday August 3, 2012 | Permalink
  15. I just sent you a detailed email with a bunch of suggestions to get this working. Please report back here with your results. Thank you.

    Posted 7 years ago on Friday August 17, 2012 | Permalink
  16. Continuing this discussion, I sent another email to you today. Thanks

    Posted 7 years ago on Friday August 31, 2012 | Permalink