PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Conditional Logic adds CSS Display:none

  1. mja850
    Member

    I migrated this site from a test server using BackupBuddy. The form worked correctly on the test site. The form now has display:none being added on the production site.

    I've searched the forums and seen a bunch of posts on this issue. I don't think I have two versions of jQuery loaded. Disabling WooCommerce makes the form appear, so there must be some kind of jQuery conflict. I'm a little baffled because the site worked on the test server.

    The URL of the form is

    Any thoughts? Thank you!

    Posted 8 years ago on Tuesday May 7, 2013 | Permalink
  2. David Peralty

    Display: none is supposed to be on the form when it has Conditional logic.

    Your site has a great deal of JavaScript errors, can you please look into rectifying them?

    Failed to load resource: the server responded with a status of 406 (Not Acceptable) http://www.tokenworks.com/wp-content/plugins/woocommerce/assets/js/jquery-cookie/jquery.cookie.min.js?ver=1.3.1
    Uncaught TypeError: Object function (e,t){return new v.fn.init(e,t,n)} has no method 'cookie' cart-fragments.min.js:1
    Invalid 'X-Frame-Options' header encountered when loading 'https://maps.google.com/maps?f=q&source=s_q&hl=en&geocode=&q=tokenworks+bro…551&ll=40.94989,-73.834476&spn=0.025931,0.031757&z=14&iwloc=A&output=embed': 'ALLOWALL' is not a recognized directive. The header will be ignored. about:blank:1
    Port error: Could not establish connection. Receiving end does not exist. miscellaneous_bindings:236
    94
    Unsafe JavaScript attempt to access frame with URL http://www.tokenworks.com/contact-us/ from frame with URL https://maps.google.com/maps?f=q&source=s_q&hl=en&geocode=&q=tokenworks+bro…551&ll=40.94989,-73.834476&spn=0.025931,0.031757&z=14&iwloc=A&output=embed. The frame requesting access has a protocol of 'https', the frame being accessed has a protocol of 'http'. Protocols must match.

    Also, can you try previewing your form in our back-end and seeing if that works?

    Posted 8 years ago on Tuesday May 7, 2013 | Permalink
  3. mja850
    Member

    Thank you! Turns out new host had mod_security turned on, which was causing one of the Woocommerce scripts not to load.

    Posted 8 years ago on Tuesday May 7, 2013 | Permalink
  4. Glad you got it working, thanks for letting us know!

    Posted 8 years ago on Tuesday May 7, 2013 | Permalink

This topic has been resolved and has been closed to new replies.